summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-17 12:51:08 +0000
committerJohn Crispin <john@openwrt.org>2015-07-17 12:51:08 +0000
commiteff79253f2fd3b4e7f1000b09e1fedf8f52d7af4 (patch)
tree133487605a1594c53a655e803ace0bb74c86148b
parent84b89e4ec459b75b40ec9a643c9aa21743ce7c81 (diff)
downloadmaster-31e0f0ae-eff79253f2fd3b4e7f1000b09e1fedf8f52d7af4.tar.gz
master-31e0f0ae-eff79253f2fd3b4e7f1000b09e1fedf8f52d7af4.tar.bz2
master-31e0f0ae-eff79253f2fd3b4e7f1000b09e1fedf8f52d7af4.zip
ramips: add support for Planex MZK-DP150N
This patch add support for Planex MZK-DP150N. a mini router on the MT7620A SoC with one Ethernet port and a 802.11n 2.4 GHz radio. Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com> SVN-Revision: 46405
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network7
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/MZK-DP150N.dts98
-rw-r--r--target/linux/ramips/image/Makefile3
-rw-r--r--target/linux/ramips/rt305x/profiles/planex.mk17
8 files changed, 135 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index fe3a79d14d..0672a2272b 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -265,6 +265,9 @@ case $board in
zte-q7)
set_wifi_led "zte:blue:status"
;;
+ mzk-dp150n)
+ ucidef_set_led_default "power" "power" "mzkdp150n:green:power" "1"
+ ;;
esac
board_config_flush
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 9fb3535149..f896afafee 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -261,6 +261,13 @@ ramips_setup_interfaces()
ucidef_add_switch_vlan "switch0" "1" "1 2 3 4 5t"
ucidef_add_switch_vlan "switch0" "2" "0 5t"
;;
+
+ mzk-dp150n)
+ ucidef_set_interface_lan "eth0.1"
+ ucidef_add_switch "switch0" "1" "1"
+ ucidef_add_switch_vlan "switch0" "1" "0 4 6t"
+ ;;
+
*)
RT3X5X=`cat /proc/cpuinfo | egrep "(RT3.5|RT5350)"`
if [ -n "${RT3X5X}" ]; then
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 46e519aa42..319763e645 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -249,6 +249,9 @@ get_status_led() {
zte-q7)
status_led="zte:red:status"
;;
+ mzk-dp150n)
+ status_led="mzkdp150n:green:power"
+ ;;
esac
}
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 3d40ab9b63..d7fd5f91aa 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -421,6 +421,9 @@ ramips_board_detect() {
*"Mediatek MT7628AN evaluation board")
name="mt7628"
;;
+ *"Planex MZK-DP150N")
+ name="mzk-dp150n"
+ ;;
*)
name="generic"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 8f45a84612..04af3225be 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -71,6 +71,7 @@ platform_check_image() {
mpr-a2 | \
mr-102n | \
mzk-w300nh2 | \
+ mzk-dp150n | \
nbg-419n | \
nw718 | \
omni-emb | \
diff --git a/target/linux/ramips/dts/MZK-DP150N.dts b/target/linux/ramips/dts/MZK-DP150N.dts
new file mode 100644
index 0000000000..ae986f76c8
--- /dev/null
+++ b/target/linux/ramips/dts/MZK-DP150N.dts
@@ -0,0 +1,98 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+ compatible = "MZK-DP150N", "ralink,rt5350-soc";
+ model = "Planex MZK-DP150N";
+
+ palmbus@10000000 {
+ gpio1: gpio@660 {
+ status = "okay";
+ };
+
+ spi@b00 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "s25fl064k";
+ reg = <0>;
+ linux,modalias = "m25p80", "s25fl064k";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "uboot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "uboot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x3b0000>;
+ };
+ };
+
+ spidev@1 {
+ compatible = "linux,spidev";
+ spi-max-frequency = <10000000>;
+ reg = <1>;
+ };
+ };
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "jtag", "uartf", "led";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ ethernet@10100000 {
+ mtd-mac-address = <&factory 0x4>;
+ };
+
+ esw@10110000 {
+ ralink,portmap = <0x17>;
+ };
+
+ wmac@10180000 {
+ ralink,mtd-eeprom = <&factory 0>;
+ ralink,led-polarity = <1>;
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ power {
+ label = "mzkdp150n:green:power";
+ gpios = <&gpio0 9 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ reset {
+ label = "reset";
+ gpios = <&gpio0 10 1>;
+ linux,code = <0x198>;
+ };
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 2fe5fdd1ab..b71d935a93 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -609,6 +609,8 @@ Image/Build/Profile/W502U=$(call BuildFirmware/Default8M/$(1),$(1),w502u,W502U)
Image/Build/Profile/WCR150GN=$(call BuildFirmware/Default4M/$(1),$(1),wcr150gn,WCR150GN)
+Image/Build/Profile/MZK-DP150N=$(call BuildFirmware/Default4M/$(1),$(1),mzk-dp150n,MZK-DP150N)
+
buffalo_whrg300n_mtd_size=3801088
define BuildFirmware/WHRG300N/squashfs
$(call BuildFirmware/Default4M/$(1),$(1),whr-g300n,WHR-G300N)
@@ -772,6 +774,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/X5,$(1))
$(call Image/Build/Profile/X8,$(1))
$(call Image/Build/Profile/XDXRN502J,$(1))
+ $(call Image/Build/Profile/MZK-DP150N,$(1))
endef
endif
diff --git a/target/linux/ramips/rt305x/profiles/planex.mk b/target/linux/ramips/rt305x/profiles/planex.mk
new file mode 100644
index 0000000000..d0d9ac949c
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/planex.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MZK-DP150N
+ NAME:=Planex MZK-DP150N
+ PACKAGES:= kmod-spi-dev
+endef
+
+define Profile/MZK-DP150N/Description
+ Package set optimized for the Planex MZK-DP150N.
+endef
+
+$(eval $(call Profile,MZK-DP150N))