summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 20:03:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 20:03:03 +0000
commitef6bc88a9ed4f036ab0aa86ad6e7923973efb1ee (patch)
treed2a2020682c9c97587077d94e209bc1886cf78b0
parentdce1bc90359b7b079d2d9cb190b0accd6bd9ae48 (diff)
downloadmaster-31e0f0ae-ef6bc88a9ed4f036ab0aa86ad6e7923973efb1ee.tar.gz
master-31e0f0ae-ef6bc88a9ed4f036ab0aa86ad6e7923973efb1ee.tar.bz2
master-31e0f0ae-ef6bc88a9ed4f036ab0aa86ad6e7923973efb1ee.zip
add uclibc portability patch (by thorsten glaser)
SVN-Revision: 5034
-rw-r--r--openwrt/toolchain/uClibc/patches/150-portability.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/openwrt/toolchain/uClibc/patches/150-portability.patch b/openwrt/toolchain/uClibc/patches/150-portability.patch
new file mode 100644
index 0000000000..b29c16ee03
--- /dev/null
+++ b/openwrt/toolchain/uClibc/patches/150-portability.patch
@@ -0,0 +1,38 @@
+Fix portability of build infrastructure
+* cp -d -> cp -P
+* tar --exclude is a GNU tar feature
+
+--- uClibc-0.9.28/Makefile.orig Sun Jun 11 19:08:56 2006
++++ uClibc-0.9.28/Makefile Sun Jun 11 19:12:05 2006
+@@ -158,12 +158,7 @@ install_dev:
+ $(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)lib
+ $(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)include
+ -$(INSTALL) -m 644 lib/*.[ao] $(PREFIX)$(DEVEL_PREFIX)lib/
+- if [ "$(KERNEL_SOURCE)" == "$(DEVEL_PREFIX)" ] ; then \
+- extra_exclude="--exclude include/linux --exclude include/asm'*'" ; \
+- else \
+- extra_exclude="" ; \
+- fi ; \
+- tar -chf - include --exclude .svn --exclude CVS $$extra_exclude \
++ tar -chf - include \
+ | tar -xf - -C $(PREFIX)$(DEVEL_PREFIX)
+ ifneq ($(strip $(UCLIBC_HAS_FLOATS)),y)
+ # Remove floating point related headers since float support is disabled.
+@@ -253,7 +248,7 @@ ifeq ($(strip $(HAVE_SHARED)),y)
+ $(INSTALL) -d $(PREFIX)$(RUNTIME_PREFIX)lib
+ $(INSTALL) -m 644 lib/lib*-$(MAJOR_VERSION).$(MINOR_VERSION).$(SUBLEVEL).so \
+ $(PREFIX)$(RUNTIME_PREFIX)lib
+- cp -dRf lib/*.so.* $(PREFIX)$(RUNTIME_PREFIX)lib
++ cp -PRf lib/*.so.* $(PREFIX)$(RUNTIME_PREFIX)lib
+ @if [ -x lib/ld-uClibc-$(MAJOR_VERSION).$(MINOR_VERSION).$(SUBLEVEL).so ] ; then \
+ set -e; \
+ $(SHELL_SET_X); \
+@@ -370,7 +365,7 @@ distclean: clean
+ release: distclean
+ cd ..; \
+ $(RM) -r uClibc-$(VERSION); \
+- cp -dRf uClibc uClibc-$(VERSION); \
++ cp -PRf uClibc uClibc-$(VERSION); \
+ find uClibc-$(VERSION)/ -type f \
+ -name .\#* -exec $(RM) -r {} \; ; \
+ find uClibc-$(VERSION)/ -type d \