summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-25 15:34:45 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-25 15:34:45 +0000
commitee0140a678a0955d0883bebcc87e7e2a42eca800 (patch)
tree9798d9fcd09ca90ed3735409274cefcfb5af6d3c
parentd84fafb9f34be7f92b01938acafcc828d9f00478 (diff)
downloadmaster-31e0f0ae-ee0140a678a0955d0883bebcc87e7e2a42eca800.tar.gz
master-31e0f0ae-ee0140a678a0955d0883bebcc87e7e2a42eca800.tar.bz2
master-31e0f0ae-ee0140a678a0955d0883bebcc87e7e2a42eca800.zip
brcm63xx: hcsimage: respect load address
Respect the vmlinux load address when generating images. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 44983
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 1913feb646..47756bf39b 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -119,7 +119,8 @@ define Image/Build/HCSDTB
# Generate the image
$(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_byte=$(4) \
--rev_maj=$(5) --rev_min=$(6) --input_file=$(KDIR)/$(7) \
- --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin
+ --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin \
+ --ldaddress=$(LOADADDR)
endef
define Image/Build/ChkDTB