summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-11-23 14:16:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-11-23 14:16:47 +0000
commited5ed9cf6f7b95bc1c22cdba85a4a3f6cb5b2c18 (patch)
treeab15ad03c35ffa91cec1d3db7bd4c299be61f535
parent25cb8318cd686a91c626c668b2ceaf85e8234d7a (diff)
downloadmaster-31e0f0ae-ed5ed9cf6f7b95bc1c22cdba85a4a3f6cb5b2c18.tar.gz
master-31e0f0ae-ed5ed9cf6f7b95bc1c22cdba85a4a3f6cb5b2c18.tar.bz2
master-31e0f0ae-ed5ed9cf6f7b95bc1c22cdba85a4a3f6cb5b2c18.zip
hostapd: fix build error on some variants with CONFIG_WPA_RFKILL_SUPPORT=y (#17765)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43345
-rw-r--r--package/network/services/hostapd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 838ef39aba..19d536ecc0 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -71,7 +71,6 @@ DRIVER_MAKEOPTS= \
CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k) \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
- $(if $(CONFIG_WPA_RFKILL_SUPPORT),NEED_RFKILL=y)
ifneq ($(LOCAL_TYPE),hostapd)
ifdef CONFIG_WPA_SUPPLICANT_OPENSSL
@@ -83,6 +82,9 @@ ifneq ($(LOCAL_TYPE),hostapd)
ifdef CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
TARGET_CFLAGS += -DNO_TIMESTAMP_CHECK
endif
+ ifdef CONFIG_WPA_RFKILL_SUPPORT)
+ DRIVER_MAKEOPTS += NEED_RFKILL=y
+ endif
DRIVER_MAKEOPTS += \
CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
endif