summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-04-13 13:38:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-04-13 13:38:45 +0000
commitec667208e67461068515f4502304f77dcd6803a4 (patch)
treee5ec52e7e124613dbca9f0254fbb00ca961431ba
parent93b8648b153836157f63850adea87b32f4b5cea8 (diff)
downloadmaster-31e0f0ae-ec667208e67461068515f4502304f77dcd6803a4.tar.gz
master-31e0f0ae-ec667208e67461068515f4502304f77dcd6803a4.tar.bz2
master-31e0f0ae-ec667208e67461068515f4502304f77dcd6803a4.zip
kernel: fix arm compressed images build on mac os x
SVN-Revision: 31274
-rw-r--r--target/linux/generic/patches-3.2/350-arm_compressed_size.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.2/350-arm_compressed_size.patch b/target/linux/generic/patches-3.2/350-arm_compressed_size.patch
new file mode 100644
index 0000000000..05d6618e91
--- /dev/null
+++ b/target/linux/generic/patches-3.2/350-arm_compressed_size.patch
@@ -0,0 +1,11 @@
+--- a/arch/arm/boot/compressed/Makefile
++++ b/arch/arm/boot/compressed/Makefile
+@@ -127,7 +127,7 @@ ccflags-y := -fpic -fno-builtin -I$(obj)
+ asflags-y := -Wa,-march=all
+
+ # Supply kernel BSS size to the decompressor via a linker symbol.
+-KBSS_SZ = $(shell size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
++KBSS_SZ = $(shell $(CROSS_COMPILE)size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
+ LDFLAGS_vmlinux = --defsym _kernel_bss_size=$(KBSS_SZ)
+ # Supply ZRELADDR to the decompressor via a linker symbol.
+ ifneq ($(CONFIG_AUTO_ZRELADDR),y)