summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-07-31 17:58:46 +0000
committerJonas Gorski <jogo@openwrt.org>2011-07-31 17:58:46 +0000
commiteb90f30ce7c4c59c4f59befd0bb0dd2735dc4f18 (patch)
tree7ecf4e6f6f6763fc948babc5b6512ecc68a5b35c
parent8fc2981bcd63547d9e45896a261918342e8137aa (diff)
downloadmaster-31e0f0ae-eb90f30ce7c4c59c4f59befd0bb0dd2735dc4f18.tar.gz
master-31e0f0ae-eb90f30ce7c4c59c4f59befd0bb0dd2735dc4f18.tar.bz2
master-31e0f0ae-eb90f30ce7c4c59c4f59befd0bb0dd2735dc4f18.zip
package/kernel: move kmod-fs-mbcache into fs-ext4
mbcache is only needed if xattr support is enabled, but this is only true for ext4 on 2.6.37+, so just bundle it with ext4 when needed. SVN-Revision: 27849
-rw-r--r--package/kernel/modules/fs.mk32
1 files changed, 9 insertions, 23 deletions
diff --git a/package/kernel/modules/fs.mk b/package/kernel/modules/fs.mk
index f7720e0e1d..c4ccf85a51 100644
--- a/package/kernel/modules/fs.mk
+++ b/package/kernel/modules/fs.mk
@@ -76,7 +76,7 @@ define KernelPackage/fs-ext2
SUBMENU:=$(FS_MENU)
TITLE:=EXT2 filesystem support
KCONFIG:=CONFIG_EXT2_FS
- DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache) @LINUX_2_6_30||LINUX_2_6_31
+ DEPENDS:=@LINUX_2_6_30||LINUX_2_6_31
FILES:=$(LINUX_DIR)/fs/ext2/ext2.ko
AUTOLOAD:=$(call AutoLoad,32,ext2,1)
endef
@@ -94,7 +94,7 @@ define KernelPackage/fs-ext3
KCONFIG:= \
CONFIG_EXT3_FS \
CONFIG_JBD
- DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache) @LINUX_2_6_30||LINUX_2_6_31
+ DEPENDS:=@LINUX_2_6_30||LINUX_2_6_31
FILES:= \
$(LINUX_DIR)/fs/ext3/ext3.ko \
$(LINUX_DIR)/fs/jbd/jbd.ko
@@ -114,11 +114,16 @@ define KernelPackage/fs-ext4
KCONFIG:= \
CONFIG_EXT4_FS \
CONFIG_JBD2
- DEPENDS:= $(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
FILES:= \
$(LINUX_DIR)/fs/ext4/ext4.ko \
$(LINUX_DIR)/fs/jbd2/jbd2.ko
- AUTOLOAD:=$(call AutoLoad,30,jbd2 ext4,1)
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),1)
+ FILES+= \
+ $(LINUX_DIR)/fs/mbcache.ko
+ AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
+ else
+ AUTOLOAD:=$(call AutoLoad,30,jbd2 ext4,1)
+ endif
$(call AddDepends/crc16)
endef
@@ -177,25 +182,6 @@ endef
$(eval $(call KernelPackage,fs-isofs))
-define KernelPackage/fs-mbcache
- SUBMENU:=$(FS_MENU)
- TITLE:=mbcache (used by ext2/ext3/ext4)
- KCONFIG:=CONFIG_FS_MBCACHE
- ifneq ($(CONFIG_FS_MBCACHE),)
- FILES:=$(LINUX_DIR)/fs/mbcache.ko
- AUTOLOAD:=$(call AutoLoad,20,mbcache,1)
- endif
-endef
-
-define KernelPackage/fs-mbcache/description
- Meta Block cache used by ext2/ext3
- This package will only be installed if extended attributes
- are enabled for ext2/ext3
-endef
-
-$(eval $(call KernelPackage,fs-mbcache))
-
-
define KernelPackage/fs-minix
SUBMENU:=$(FS_MENU)
TITLE:=Minix filesystem support