summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-22 09:11:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-22 09:11:25 +0000
commitea0ff700e890410d322b411586cf6065c48ab31a (patch)
treea8ef14bd3d3ef8d108827b43bf14d37f1ac3717f
parent48a3a30feca6a7fb5416656b53fbbfe733652714 (diff)
downloadmaster-31e0f0ae-ea0ff700e890410d322b411586cf6065c48ab31a.tar.gz
master-31e0f0ae-ea0ff700e890410d322b411586cf6065c48ab31a.tar.bz2
master-31e0f0ae-ea0ff700e890410d322b411586cf6065c48ab31a.zip
ar71xx: image: add mtdpartsize macro
The new macro will be used to determine the firmware partition size from an MTD layout. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38117
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 60990b284d..8ac70448d5 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -31,6 +31,10 @@ define mkcmdline
$(if $(1),board=$(1) )$(if $(2),console=$(2)$(COMMA)$(3))
endef
+define mtdpartsize
+$(shell echo $$((`echo '$(2)' | sed -e 's/.*[:$(COMMA)]\([0-9]*\)k[@]*[0-9a-zx]*($(1)).*/\1/'` * 1024)))
+endef
+
SINGLE_PROFILES:=
define SingleProfile