summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-03-13 12:18:35 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-03-13 12:18:35 +0000
commite86198fcce29c90186c4433b5665e0b1386c9c96 (patch)
treeb848c3893e6c48576d25d4c38ca92bfcda2c0389
parentf7809d07c868d7f0e5542c8157d1e3e0aadad5fe (diff)
downloadmaster-31e0f0ae-e86198fcce29c90186c4433b5665e0b1386c9c96.tar.gz
master-31e0f0ae-e86198fcce29c90186c4433b5665e0b1386c9c96.tar.bz2
master-31e0f0ae-e86198fcce29c90186c4433b5665e0b1386c9c96.zip
Small bug fix to package/kernel/modules/other.mk stty broken in busybox 1.4.1, added patch with fixed code from BB SVN. This will need to be removed when 1.4.2 is released.
SVN-Revision: 6559
-rw-r--r--package/busybox/patches/930-stty_bug_fix.patch26
-rw-r--r--package/kernel/modules/other.mk2
2 files changed, 27 insertions, 1 deletions
diff --git a/package/busybox/patches/930-stty_bug_fix.patch b/package/busybox/patches/930-stty_bug_fix.patch
new file mode 100644
index 0000000000..f33e6b55f8
--- /dev/null
+++ b/package/busybox/patches/930-stty_bug_fix.patch
@@ -0,0 +1,26 @@
+--- build_arm/busybox-1.4.1/coreutils/stty.c.old 2007-03-13 12:59:49.000000000 +0100
++++ build_arm/busybox-1.4.1/coreutils/stty.c 2007-03-13 07:51:38.000000000 +0100
+@@ -568,10 +568,11 @@
+ NULL
+ };
+ int i = index_in_str_array(params, name);
+- if (i) {
+- if (!(i == 4 || i == 5))
+- i |= 0x80;
+- }
++ if (i < 0)
++ return 0;
++ if (!(i == 4 || i == 5))
++ i |= 0x80;
++
+ return i;
+ }
+
+@@ -907,6 +908,7 @@
+ #define STTY_verbose_output (1<<2)
+ #define STTY_recoverable_output (1<<3)
+ #define STTY_noargs (1<<4)
++int stty_main(int argc, char **argv);
+ int stty_main(int argc, char **argv)
+ {
+ struct termios mode;
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 1a38db6dfa..9a43bc7901 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -228,7 +228,7 @@ define KernelPackage/mmc/2.6
FILES:= \
$(MODULES_DIR)/kernel/drivers/mmc/mmc_core.$(LINUX_KMOD_SUFFIX) \
$(MODULES_DIR)/kernel/drivers/mmc/mmc_block.$(LINUX_KMOD_SUFFIX) \
- $(MODULES_DIR)/kernel/drivers/mmc/at91_mci.$(LINUX_KMOD_SUFFIX) \
+ $(MODULES_DIR)/kernel/drivers/mmc/at91_mci.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,90,mmc_core mmc_block at91_mci)
endef
$(eval $(call KernelPackage,mmc))