summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-12-16 10:37:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-12-16 10:37:14 +0000
commite7336673b14fe311ae493eee86ba8983792bcf02 (patch)
tree3b4a267cc924fd6ce99ea752b9be8adb4a416b7b
parentb2946e7e8aca243281e7ee95e5d17165039970f0 (diff)
downloadmaster-31e0f0ae-e7336673b14fe311ae493eee86ba8983792bcf02.tar.gz
master-31e0f0ae-e7336673b14fe311ae493eee86ba8983792bcf02.tar.bz2
master-31e0f0ae-e7336673b14fe311ae493eee86ba8983792bcf02.zip
update to 2.6.27.9 and refresh patches
SVN-Revision: 13659
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/au1000/Makefile2
-rw-r--r--target/linux/avr32/Makefile2
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/971-ocf_20080917.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/975-crypto_kconfig_hacks.patch6
-rw-r--r--target/linux/olpc/Makefile2
-rw-r--r--target/linux/ppc40x/Makefile2
-rw-r--r--target/linux/ppc44x/Makefile2
-rw-r--r--target/linux/ps3/Makefile2
-rw-r--r--target/linux/x86/Makefile2
11 files changed, 14 insertions, 14 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index e8c84a0eaa..78b0508b85 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -28,8 +28,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.26.8)
LINUX_KERNEL_MD5SUM:=05dd0d4f8f110b4219ae6ec7a36c046d
endif
-ifeq ($(LINUX_VERSION),2.6.27.8)
- LINUX_KERNEL_MD5SUM:=cbdc1b350ef79dd323b9aeda5cf7f1b6
+ifeq ($(LINUX_VERSION),2.6.27.9)
+ LINUX_KERNEL_MD5SUM:=0ca39bec243b1d90f496da021b7487f1
endif
# disable the md5sum check for unknown kernel versions
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index d8519d776a..1ab9bc5cb0 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -11,7 +11,7 @@ BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci
-LINUX_VERSION:=2.6.27.8
+LINUX_VERSION:=2.6.27.9
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += yamonenv
diff --git a/target/linux/avr32/Makefile b/target/linux/avr32/Makefile
index ea46a321a3..27766bea18 100644
--- a/target/linux/avr32/Makefile
+++ b/target/linux/avr32/Makefile
@@ -10,7 +10,7 @@ ARCH:=avr32
BOARD:=avr32
BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
-LINUX_VERSION:=2.6.27.8
+LINUX_VERSION:=2.6.27.9
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index a685833307..ba4dc0c9e6 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm
-LINUX_VERSION:=2.6.27.8
+LINUX_VERSION:=2.6.27.9
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/generic-2.6/patches-2.6.27/971-ocf_20080917.patch b/target/linux/generic-2.6/patches-2.6.27/971-ocf_20080917.patch
index cf870e231e..c18eea40ce 100644
--- a/target/linux/generic-2.6/patches-2.6.27/971-ocf_20080917.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/971-ocf_20080917.patch
@@ -88,7 +88,7 @@
/*********************************************************************
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
-@@ -139,6 +139,7 @@ asmlinkage long sys_dup(unsigned int fil
+@@ -140,6 +140,7 @@ asmlinkage long sys_dup(unsigned int fil
}
return ret;
}
diff --git a/target/linux/generic-2.6/patches-2.6.27/975-crypto_kconfig_hacks.patch b/target/linux/generic-2.6/patches-2.6.27/975-crypto_kconfig_hacks.patch
index ad85e43e53..ebf201b7bb 100644
--- a/target/linux/generic-2.6/patches-2.6.27/975-crypto_kconfig_hacks.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/975-crypto_kconfig_hacks.patch
@@ -1,6 +1,6 @@
---- a/crypto/Kconfig 2008-12-12 00:28:55.000000000 +0100
-+++ b/crypto/Kconfig 2008-12-12 00:29:33.000000000 +0100
-@@ -22,20 +22,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -22,20 +22,20 @@ if CRYPTO
comment "Crypto core or helper"
config CRYPTO_ALGAPI
diff --git a/target/linux/olpc/Makefile b/target/linux/olpc/Makefile
index 2860feb30d..6e00f193f8 100644
--- a/target/linux/olpc/Makefile
+++ b/target/linux/olpc/Makefile
@@ -11,7 +11,7 @@ BOARD:=olpc
BOARDNAME:=OLPC XO-1
FEATURES:=squashfs ext2
-LINUX_VERSION:=2.6.27.8
+LINUX_VERSION:=2.6.27.9
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index 44a4af86f2..f19864d188 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -11,7 +11,7 @@ BOARD:=ppc40x
BOARDNAME:=AMCC/IBM PPC40x
FEATURES:=squashfs
-LINUX_VERSION:=2.6.27.8
+LINUX_VERSION:=2.6.27.9
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index 1e5639735e..c2dee41aff 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -11,7 +11,7 @@ BOARD:=ppc44x
BOARDNAME:=AMCC/IBM PPC44x
FEATURES:=squashfs
-LINUX_VERSION:=2.6.27.8
+LINUX_VERSION:=2.6.27.9
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ps3/Makefile b/target/linux/ps3/Makefile
index 098fbd1974..ebcc4a9cf0 100644
--- a/target/linux/ps3/Makefile
+++ b/target/linux/ps3/Makefile
@@ -10,7 +10,7 @@ ARCH:=powerpc
BOARD:=ps3
BOARDNAME:=Sony PS3 Game Console
-LINUX_VERSION:=2.6.27.8
+LINUX_VERSION:=2.6.27.9
KERNEL_CC:=
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 30104153f5..131bd37c63 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi vmdk
SUBTARGETS=generic
-LINUX_VERSION:=2.6.27.8
+LINUX_VERSION:=2.6.27.9
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci