summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2013-07-13 22:43:10 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2013-07-13 22:43:10 +0000
commite574f75d16374d3454bcb44b3fb9ab94f0f88765 (patch)
treecad09a4a4c17651a3b3422ba5804665dd32f9cc7
parent9b9c6facfc9f887e5bee3628752ff4572730fbfa (diff)
downloadmaster-31e0f0ae-e574f75d16374d3454bcb44b3fb9ab94f0f88765.tar.gz
master-31e0f0ae-e574f75d16374d3454bcb44b3fb9ab94f0f88765.tar.bz2
master-31e0f0ae-e574f75d16374d3454bcb44b3fb9ab94f0f88765.zip
kernel: update to kernel 3.9.10 and refresh patches
SVN-Revision: 37274
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar7/Makefile2
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/gemini/Makefile2
-rw-r--r--target/linux/generic/patches-3.9/204-module_strip.patch4
-rw-r--r--target/linux/generic/patches-3.9/260-crypto_test_dependencies.patch4
-rw-r--r--target/linux/generic/patches-3.9/531-debloat_lzma.patch39
-rw-r--r--target/linux/ramips/Makefile2
8 files changed, 31 insertions, 28 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 340cb4da61..96b2575aac 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -14,8 +14,8 @@ endif
ifeq ($(LINUX_VERSION),3.8.13)
LINUX_KERNEL_MD5SUM:=2af19d06cd47ec459519159cdd10542d
endif
-ifeq ($(LINUX_VERSION),3.9.8)
- LINUX_KERNEL_MD5SUM:=04d74575ef1c484ad00be61f32bb4557
+ifeq ($(LINUX_VERSION),3.9.10)
+ LINUX_KERNEL_MD5SUM:=2d69615f7074b952cfcb65f1356c0cc9
endif
ifeq ($(LINUX_VERSION),3.10)
LINUX_KERNEL_MD5SUM:=4f25cd5bec5f8d5a7d935b3f2ccb8481
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
index d875a7a5bb..1ee72ae4e9 100644
--- a/target/linux/ar7/Makefile
+++ b/target/linux/ar7/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs atm
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
SUBTARGETS:=generic ac49x
-LINUX_VERSION:=3.9.8
+LINUX_VERSION:=3.9.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index f47b505ca8..c2cbdf6c36 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
SUBTARGETS:=generic smp
FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.9.8
+LINUX_VERSION:=3.9.10
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/gemini/Makefile b/target/linux/gemini/Makefile
index 9da59cbc5f..daa46889a3 100644
--- a/target/linux/gemini/Makefile
+++ b/target/linux/gemini/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs pci
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.9.8
+LINUX_VERSION:=3.9.10
KERNELNAME:="zImage"
diff --git a/target/linux/generic/patches-3.9/204-module_strip.patch b/target/linux/generic/patches-3.9/204-module_strip.patch
index 4b45156e02..6a7da5596b 100644
--- a/target/linux/generic/patches-3.9/204-module_strip.patch
+++ b/target/linux/generic/patches-3.9/204-module_strip.patch
@@ -78,7 +78,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
#ifdef MODULE
#define __MODULE_INFO(tag, name, info) \
static const char __UNIQUE_ID(name)[] \
-@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]
+@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]
= __stringify(tag) "=" info
#else /* !MODULE */
/* This struct is here for syntactic coherency, it is not used */
@@ -88,7 +88,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
#endif
#define __MODULE_PARM_TYPE(name, _type) \
__MODULE_INFO(parmtype, name##type, #name ":" _type)
-@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]
+@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]
/* One for each parameter, describing how to use it. Some files do
multiple of these per line, so can't just use MODULE_INFO. */
#define MODULE_PARM_DESC(_parm, desc) \
diff --git a/target/linux/generic/patches-3.9/260-crypto_test_dependencies.patch b/target/linux/generic/patches-3.9/260-crypto_test_dependencies.patch
index 8cc15e470b..a28f69308c 100644
--- a/target/linux/generic/patches-3.9/260-crypto_test_dependencies.patch
+++ b/target/linux/generic/patches-3.9/260-crypto_test_dependencies.patch
@@ -17,7 +17,7 @@
tristate "Userspace cryptographic algorithm configuration"
--- a/crypto/algboss.c
+++ b/crypto/algboss.c
-@@ -247,6 +247,9 @@ static int cryptomgr_schedule_test(struc
+@@ -248,6 +248,9 @@ static int cryptomgr_schedule_test(struc
type = alg->cra_flags;
/* This piece of crap needs to disappear into per-type test hooks. */
@@ -27,7 +27,7 @@
if ((!((type ^ CRYPTO_ALG_TYPE_BLKCIPHER) &
CRYPTO_ALG_TYPE_BLKCIPHER_MASK) && !(type & CRYPTO_ALG_GENIV) &&
((alg->cra_flags & CRYPTO_ALG_TYPE_MASK) ==
-@@ -255,6 +258,7 @@ static int cryptomgr_schedule_test(struc
+@@ -256,6 +259,7 @@ static int cryptomgr_schedule_test(struc
(!((type ^ CRYPTO_ALG_TYPE_AEAD) & CRYPTO_ALG_TYPE_MASK) &&
alg->cra_type == &crypto_nivaead_type && alg->cra_aead.ivsize))
type |= CRYPTO_ALG_TESTED;
diff --git a/target/linux/generic/patches-3.9/531-debloat_lzma.patch b/target/linux/generic/patches-3.9/531-debloat_lzma.patch
index 9f9690f187..aa3c498016 100644
--- a/target/linux/generic/patches-3.9/531-debloat_lzma.patch
+++ b/target/linux/generic/patches-3.9/531-debloat_lzma.patch
@@ -124,7 +124,7 @@
/* LzmaDecode
--- a/lib/lzma/LzmaDec.c
+++ b/lib/lzma/LzmaDec.c
-@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
+@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
p->needFlush = 0;
}
@@ -219,26 +219,26 @@
{
UInt32 dicSize;
Byte d;
-@@ -935,33 +883,11 @@ static SRes LzmaDec_AllocateProbs2(CLzma
+@@ -935,7 +883,7 @@ static SRes LzmaDec_AllocateProbs2(CLzma
return SZ_OK;
}
-SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
--{
-- CLzmaProps propNew;
-- RINOK(LzmaProps_Decode(&propNew, props, propsSize));
-- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
-- p->prop = propNew;
-- return SZ_OK;
--}
--
--SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
+static SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
{
CLzmaProps propNew;
-- SizeT dicBufSize;
RINOK(LzmaProps_Decode(&propNew, props, propsSize));
- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
+@@ -943,28 +891,6 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
+ p->prop = propNew;
+ return SZ_OK;
+ }
+-
+-SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
+-{
+- CLzmaProps propNew;
+- SizeT dicBufSize;
+- RINOK(LzmaProps_Decode(&propNew, props, propsSize));
+- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
- dicBufSize = propNew.dicSize;
- if (p->dic == 0 || dicBufSize != p->dicBufSize)
- {
@@ -251,9 +251,12 @@
- }
- }
- p->dicBufSize = dicBufSize;
- p->prop = propNew;
- return SZ_OK;
- }
+- p->prop = propNew;
+- return SZ_OK;
+-}
+
+ SRes LzmaDecode(Byte *dest, SizeT *destLen, const Byte *src, SizeT *srcLen,
+ const Byte *propData, unsigned propSize, ELzmaFinishMode finishMode,
--- a/include/linux/lzma/LzmaEnc.h
+++ b/include/linux/lzma/LzmaEnc.h
@@ -31,9 +31,6 @@ typedef struct _CLzmaEncProps
@@ -597,7 +600,7 @@
void MatchFinder_Construct(CMatchFinder *p);
/* Conditions:
-@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
+@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
ISzAlloc *alloc);
void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
@@ -686,7 +689,7 @@
{
memmove(p->bufferBase,
p->buffer - p->keepSizeBefore,
-@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder
+@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder
p->buffer = p->bufferBase + p->keepSizeBefore;
}
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index 3975cba765..6f0a58deb3 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883 mt7620a
CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
FEATURES:=squashfs gpio
-LINUX_VERSION:=3.9.8
+LINUX_VERSION:=3.9.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\