summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 15:45:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 15:45:36 +0000
commite3fb07bc7890d346330f9b9bec221b1f77a6a9c0 (patch)
tree620a2c71ef5f0d8b51d78a80dee750d848d47978
parentaf7a470f9c3f0c8546a90ae24a8494d3ee94efd6 (diff)
downloadmaster-31e0f0ae-e3fb07bc7890d346330f9b9bec221b1f77a6a9c0.tar.gz
master-31e0f0ae-e3fb07bc7890d346330f9b9bec221b1f77a6a9c0.tar.bz2
master-31e0f0ae-e3fb07bc7890d346330f9b9bec221b1f77a6a9c0.zip
add support for Package/<pkgname>/description - old format still supported, but deprecated
SVN-Revision: 5015
-rw-r--r--openwrt/include/package.mk9
-rw-r--r--openwrt/package/busybox/Makefile8
2 files changed, 13 insertions, 4 deletions
diff --git a/openwrt/include/package.mk b/openwrt/include/package.mk
index 181ea32b6e..7ae95f8fe8 100644
--- a/openwrt/include/package.mk
+++ b/openwrt/include/package.mk
@@ -169,6 +169,8 @@ define BuildPackage
echo "Default: $(DEFAULT)";
endif
+ $(call shexport,Package/$(1)/description)
+
DUMPINFO += \
if [ "$$$$PREREQ_CHECK" = 1 ]; then echo "Prereq-Check: 1"; fi; \
echo "Version: $(VERSION)"; \
@@ -176,7 +178,12 @@ define BuildPackage
echo "Build-Depends: $(PKG_BUILDDEP)"; \
echo "Category: $(CATEGORY)"; \
echo "Title: $(TITLE)"; \
- echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g'; \
+ if isset $(call shvar,Package/$(1)/description); then \
+ echo -n "Description: "; \
+ getvar $(call shvar,Package/$(1)/description); \
+ else \
+ echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g'; \
+ fi;
ifneq ($(URL),)
DUMPINFO += \
diff --git a/openwrt/package/busybox/Makefile b/openwrt/package/busybox/Makefile
index f56d2462d7..05174a32bd 100644
--- a/openwrt/package/busybox/Makefile
+++ b/openwrt/package/busybox/Makefile
@@ -26,13 +26,15 @@ define Package/busybox
CATEGORY:=Base system
DEFAULT:=y
TITLE:=Core utilities for embedded Linux
- DESCRIPTION:=\
- The Swiss Army Knife of embedded Linux. \\\
- It slices, it dices, it makes Julian Fries.
URL:=http://busybox.net/
MENU:=1
endef
+define Package/busybox/description
+The Swiss Army Knife of embedded Linux.
+ It slices, it dices, it makes Julian Fries.
+endef
+
define Package/busybox/config
menu "Configuration"
depends on PACKAGE_busybox