summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-03 13:19:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-03 13:19:41 +0000
commite08253b1c225acb88456c3596c8467f3948b3875 (patch)
tree67b3a5ee601254f0fa7050d8202f63c482364670
parent6acecfb3cdfe458308337ed89d43040dddc3fcf6 (diff)
downloadmaster-31e0f0ae-e08253b1c225acb88456c3596c8467f3948b3875.tar.gz
master-31e0f0ae-e08253b1c225acb88456c3596c8467f3948b3875.tar.bz2
master-31e0f0ae-e08253b1c225acb88456c3596c8467f3948b3875.zip
change the an openssl sed command to be safe for -Wl,-rpath-link in ldflags
SVN-Revision: 12511
-rw-r--r--package/openssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index f19551df3d..dce7550538 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -122,7 +122,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
mkdir -p $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
- $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
endef
define Package/libopenssl/install