summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-05 11:50:42 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-05 11:50:42 +0000
commite0342d268400cf810c737d98f79dbc12144d53d9 (patch)
tree9242685f8d67c622c9b225c29c4496b1434d4d1e
parentc79ddb37738ff54908d4d79ddddcc7cd6d8e0647 (diff)
downloadmaster-31e0f0ae-e0342d268400cf810c737d98f79dbc12144d53d9.tar.gz
master-31e0f0ae-e0342d268400cf810c737d98f79dbc12144d53d9.tar.bz2
master-31e0f0ae-e0342d268400cf810c737d98f79dbc12144d53d9.zip
sdk: don't try to build in-kernel kmods
We don't ship the kernel sources, so using the base git as a feed will fail when trying to build kernel modules with separate install steps. Instead of trying to fixup the install steps, let's just skip building kernel modules alltogether and just create empty packages. Out-of-kernel modules are still expected to exist and are packaged, as for these sources are fetched during the normal build steps. Reported-by: Jo-Philipp Wich <jow@openwrt.org> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 43525
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 01fb4dbd81..d2754abe44 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -167,7 +167,7 @@ $(call KernelPackage/$(1)/config)
$(call KernelPackage/depends)
ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m y,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
- ifneq ($(strip $(FILES)),)
+ ifneq ($(if $(SDK),$(filter-out $(LINUX_DIR)/%.ko,$(FILES)),$(strip $(FILES))),)
define Package/kmod-$(1)/install
@for mod in $$(FILES); do \
if [ -e $$$$$$$$mod ]; then \