summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-03-24 10:06:40 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-03-24 10:06:40 +0000
commitd830d34b000551a2c288d09dbfeaa8010f22d372 (patch)
treef157a516dd4f0b5e2fb27324f55e883a7e47d275
parent76bf68fa52221173451d172511228fef091a1f68 (diff)
downloadmaster-31e0f0ae-d830d34b000551a2c288d09dbfeaa8010f22d372.tar.gz
master-31e0f0ae-d830d34b000551a2c288d09dbfeaa8010f22d372.tar.bz2
master-31e0f0ae-d830d34b000551a2c288d09dbfeaa8010f22d372.zip
x86_64: fix PARTUUID format with leading zeros
Otherwise the root device won't be found in 1/16 of the generated images (whenever the signature starts with a zero digit). Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 44959
-rw-r--r--target/linux/x86_64/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86_64/image/Makefile b/target/linux/x86_64/image/Makefile
index e8d9ac1158..cd80bb1de8 100644
--- a/target/linux/x86_64/image/Makefile
+++ b/target/linux/x86_64/image/Makefile
@@ -40,7 +40,7 @@ ifneq ($(GRUB_TERMINALS),)
GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
endif
-SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%02x"')
+SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%08x"')
ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)