summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-07 11:32:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-07 11:32:09 +0000
commitd3f412f4ec3a6e47297ab22c60208394aed9b03c (patch)
tree398b2c1e87c2cbd8c533765f33d8ae407b63ccfe
parent59cf6711609e14d7d0adb4fd729e3bfa3b13bda6 (diff)
downloadmaster-31e0f0ae-d3f412f4ec3a6e47297ab22c60208394aed9b03c.tar.gz
master-31e0f0ae-d3f412f4ec3a6e47297ab22c60208394aed9b03c.tar.bz2
master-31e0f0ae-d3f412f4ec3a6e47297ab22c60208394aed9b03c.zip
rename PATCH to KPATCH
SVN-Revision: 23286
-rw-r--r--include/quilt.mk4
-rw-r--r--rules.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 6c4839ba4a..9309fc94b7 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -42,9 +42,9 @@ define PatchDir/Default
@if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
if [ -s "$(2)/series" ]; then \
$(call filter_series,$(2)/series) | xargs -n1 \
- $(PATCH) "$(1)" "$(2)"; \
+ $(KPATCH) "$(1)" "$(2)"; \
else \
- $(PATCH) "$(1)" "$(2)"; \
+ $(KPATCH) "$(1)" "$(2)"; \
fi; \
fi
endef
diff --git a/rules.mk b/rules.mk
index c0004d8088..49044c8cfb 100644
--- a/rules.mk
+++ b/rules.mk
@@ -160,7 +160,7 @@ HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib
TARGET_CC:=$(TARGET_CROSS)gcc
TARGET_CXX:=$(if $(CONFIG_INSTALL_LIBSTDCPP),$(TARGET_CROSS)g++,no)
-PATCH:=$(SCRIPT_DIR)/patch-kernel.sh
+KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh
SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
CP:=cp -fpR
LN:=ln -sf