summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-02 01:38:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-02 01:38:07 +0000
commitd2c8e9104d4358641a5548b17a2c6b759ef4298b (patch)
tree27efd2fdefcd2bb14805781f454c8f4faf4246e1
parent68ca8e7818356c0dbf2e0400b177139a656791c0 (diff)
downloadmaster-31e0f0ae-d2c8e9104d4358641a5548b17a2c6b759ef4298b.tar.gz
master-31e0f0ae-d2c8e9104d4358641a5548b17a2c6b759ef4298b.tar.bz2
master-31e0f0ae-d2c8e9104d4358641a5548b17a2c6b759ef4298b.zip
add squashfs support for atheros-2.6
SVN-Revision: 6451
-rw-r--r--target/linux/atheros-2.6/Makefile4
-rw-r--r--target/linux/atheros-2.6/image/Makefile5
2 files changed, 7 insertions, 2 deletions
diff --git a/target/linux/atheros-2.6/Makefile b/target/linux/atheros-2.6/Makefile
index 92f9d361c4..5404902f37 100644
--- a/target/linux/atheros-2.6/Makefile
+++ b/target/linux/atheros-2.6/Makefile
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
ARCH:=mips
BOARD:=atheros
BOARDNAME:=Atheros
-FEATURES:=jffs2
+FEATURES:=squashfs jffs2
define Target/Description
- Build firmware images for Atheros SoC boards (currently AR2315-AR2317)
+ Build firmware images for Atheros SoC boards
endef
include $(INCLUDE_DIR)/kernel-build.mk
diff --git a/target/linux/atheros-2.6/image/Makefile b/target/linux/atheros-2.6/image/Makefile
index 80e3335920..dfd1746fd3 100644
--- a/target/linux/atheros-2.6/image/Makefile
+++ b/target/linux/atheros-2.6/image/Makefile
@@ -19,7 +19,12 @@ define Image/BuildKernel
dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.gz bs=65536 conv=sync
endef
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
define Image/Build
+ $(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-root.$(1) bs=128k conv=sync
endef