summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>2009-07-01 17:07:52 +0000
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>2009-07-01 17:07:52 +0000
commitd0a129742f957911f6c13ef3bfc9a1671fdae351 (patch)
treea81179df359520a44f378d6951236623fe54d43e
parent9e9480699070c69ad45dcba5aeb26017a2c08137 (diff)
downloadmaster-31e0f0ae-d0a129742f957911f6c13ef3bfc9a1671fdae351.tar.gz
master-31e0f0ae-d0a129742f957911f6c13ef3bfc9a1671fdae351.tar.bz2
master-31e0f0ae-d0a129742f957911f6c13ef3bfc9a1671fdae351.zip
madwifi: Disable compression capability on AR71XX and make it optional for other platforms (thanks to David A. Bandel and Dennis Bartsch)
SVN-Revision: 16642
-rw-r--r--package/madwifi/Config.in8
-rw-r--r--package/madwifi/Makefile6
2 files changed, 13 insertions, 1 deletions
diff --git a/package/madwifi/Config.in b/package/madwifi/Config.in
index 6191ce2db4..23cc433f3d 100644
--- a/package/madwifi/Config.in
+++ b/package/madwifi/Config.in
@@ -5,6 +5,14 @@ config MADWIFI_DEBUG
depends on DEVEL && PACKAGE_kmod-madwifi
default n
+config MADWIFI_COMPRESSION
+ bool "Enable Atheros Super A/G Compression"
+ depends on PACKAGE_kmod-madwifi
+ depends !TARGET_ar71xx
+ default n
+ help
+ Enables Atheros Super A/G Hardware Compression Engine.
+
choice
prompt "Madwifi version"
depends on PACKAGE_kmod-madwifi
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 93f695db95..5e6273ccae 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -46,7 +46,11 @@ PKG_BUILD_DEPENDS:=wprobe
include $(INCLUDE_DIR)/package.mk
-COMPRESSION:=1
+ifdef CONFIG_MADWIFI_COMPRESSION
+ COMPRESSION:=1
+else
+ COMPRESSION:=0
+endif
define Download/hal
FILE:=$(HAL_FILE)