summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-15 11:37:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-15 11:37:07 +0000
commitcfbb7d9b228117a195e2bfca8a837b6568493b44 (patch)
tree697606a83d43ace882e17fae6db6f3c372eb6aad
parentfb2b3c9eae51c1c8f14fc7f27bdc7255bdb43f67 (diff)
downloadmaster-31e0f0ae-cfbb7d9b228117a195e2bfca8a837b6568493b44.tar.gz
master-31e0f0ae-cfbb7d9b228117a195e2bfca8a837b6568493b44.tar.bz2
master-31e0f0ae-cfbb7d9b228117a195e2bfca8a837b6568493b44.zip
hostapd: enable parallel build
SVN-Revision: 33419
-rw-r--r--package/hostapd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 295efd0cc3..5e2452e437 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -19,6 +19,8 @@ PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_SOURCE_PROTO:=git
PKG_MIRROR_MD5SUM:=2732dbca58b0aaaebdad69e13588d058
+PKG_BUILD_PARALLEL:=1
+
PKG_BUILD_DEPENDS:= \
PACKAGE_kmod-madwifi:madwifi \
@@ -232,7 +234,7 @@ endif
define Build/RunMake
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
- $(MAKE) -C $(PKG_BUILD_DIR)/$(1) \
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/$(1) \
$(TARGET_CONFIGURE_OPTS) \
$(DRIVER_MAKEOPTS) \
LIBS="$(TARGET_LDFLAGS)" \