summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-07-11 13:29:57 +0000
committerRod Whitby <rod@whitby.id.au>2007-07-11 13:29:57 +0000
commitce7b825d9a157f0965756ab20936e8672c918630 (patch)
treea9f532ce2659ae87318a90d800c5f523aea32ea0
parent04673803b549e7abc580acb012ad9fb30764ef8b (diff)
downloadmaster-31e0f0ae-ce7b825d9a157f0965756ab20936e8672c918630.tar.gz
master-31e0f0ae-ce7b825d9a157f0965756ab20936e8672c918630.tar.bz2
master-31e0f0ae-ce7b825d9a157f0965756ab20936e8672c918630.zip
ixp4xx: Initial profile for the Freecom FSG-3
SVN-Revision: 7920
-rw-r--r--target/linux/ixp4xx-2.6/config/profile-FSG316
-rw-r--r--target/linux/ixp4xx-2.6/profiles/500-FSG3.mk20
2 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/ixp4xx-2.6/config/profile-FSG3 b/target/linux/ixp4xx-2.6/config/profile-FSG3
new file mode 100644
index 0000000000..051031d070
--- /dev/null
+++ b/target/linux/ixp4xx-2.6/config/profile-FSG3
@@ -0,0 +1,16 @@
+CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
+CONFIG_ATA=y
+CONFIG_SATA_VIA=y
+CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_EHCI_SPLIT_ISO=y
+CONFIG_USB_EHCI_ROOT_HUB_TT=y
+CONFIG_USB_EHCI_TT_NEWSCHED=y
+CONFIG_USB_OHCI_HCD=y
+CONFIG_USB_OHCI_LITTLE_ENDIAN=y
+CONFIG_USB_STORAGE=y
+CONFIG_EXT3_FS=y
+CONFIG_EXT3_FS_XATTR=y
+CONFIG_EXT3_FS_POSIX_ACL=y
+CONFIG_EXT3_FS_SECURITY=y
+CONFIG_JBD=y
+CONFIG_FS_MBCACHE=y
diff --git a/target/linux/ixp4xx-2.6/profiles/500-FSG3.mk b/target/linux/ixp4xx-2.6/profiles/500-FSG3.mk
new file mode 100644
index 0000000000..d7d6a2ef75
--- /dev/null
+++ b/target/linux/ixp4xx-2.6/profiles/500-FSG3.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FSG3
+ NAME:=Freecom FSG-3
+ PACKAGES:= \
+ kmod-madwifi wireless-tools \
+ kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2
+endef
+
+define Profile/FSG3/Description
+ Package set optimized for the Freecom FSG-3
+endef
+$(eval $(call Profile,FSG3))
+