summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 17:13:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 17:13:40 +0000
commitcd3f8b5e654be9aa187a560cd23019e1e25bc84b (patch)
tree99174e61d197b91c62ac547e12d6e30bf61ec3c6
parentb806e425a31fc4cf07493e737d526bb0b21463fb (diff)
downloadmaster-31e0f0ae-cd3f8b5e654be9aa187a560cd23019e1e25bc84b.tar.gz
master-31e0f0ae-cd3f8b5e654be9aa187a560cd23019e1e25bc84b.tar.bz2
master-31e0f0ae-cd3f8b5e654be9aa187a560cd23019e1e25bc84b.zip
don't touch TAR_OPTIONS in host.mk
SVN-Revision: 5024
-rw-r--r--openwrt/include/host.mk2
-rw-r--r--openwrt/toolchain/kernel-headers/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/include/host.mk b/openwrt/include/host.mk
index 93f86dce8a..9eee20fcfb 100644
--- a/openwrt/include/host.mk
+++ b/openwrt/include/host.mk
@@ -23,6 +23,6 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-e 's/i[3-9]86/i386/'`" >> $@
@echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
@if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
- echo "TAR_OPTIONS+=--wildcards" >> $@; \
+ echo "TAR_WILDCARDS:=--wildcards" >> $@; \
fi
diff --git a/openwrt/toolchain/kernel-headers/Makefile b/openwrt/toolchain/kernel-headers/Makefile
index 3e2cd2ae86..a893b8511c 100644
--- a/openwrt/toolchain/kernel-headers/Makefile
+++ b/openwrt/toolchain/kernel-headers/Makefile
@@ -32,7 +32,7 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
define Build/Prepare
mkdir -p $(TOOLCHAIN_BUILD_DIR)
- bzcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
+ bzcat $(DL_DIR)/$(PKG_SOURCE) | tar $(TAR_WILDCARDS) -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
linux-$(PKG_VERSION)/include \
linux-$(PKG_VERSION)/Makefile \
linux-$(PKG_VERSION)/Rules.make \