summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-30 18:30:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-30 18:30:59 +0000
commitcb67115b4c886556aa8b271f422b18d0d141b251 (patch)
tree6c5ce9f243e27a24f57fa1a5cbf76e6f95cf3f5c
parentfd8e5b04b45b06a27835aee72f774d958967b6c1 (diff)
downloadmaster-31e0f0ae-cb67115b4c886556aa8b271f422b18d0d141b251.tar.gz
master-31e0f0ae-cb67115b4c886556aa8b271f422b18d0d141b251.tar.bz2
master-31e0f0ae-cb67115b4c886556aa8b271f422b18d0d141b251.zip
ar71xx: image: fix CyberTAN sysupgrade images
In the current sysupgrade images, the CRC32 value of the TRX header covers the whole rootfs data. Due to this, the CRC value should be changed during sysupgrade otherwise the bootloader refuses to load the image on the next boot. Change the image generation to create sysupgrade images where the CRC32 value covers the kernel data only. This allows to skip the 'fixtrx' step during sysupgrade on the target. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38964
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 8511bba350..dee44077bf 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -668,11 +668,15 @@ Image/Build/CyberTAN/loader=$(call Image/BuildLoader,$(1),gz,$(2),0x80060000)
Image/Build/CyberTAN/buildkernel=$(call MkuImage,gzip,,$(KDIR)/loader-$(2).gz,$(KDIR_TMP)/vmlinux-$(2).uImage)
define Image/Build/CyberTAN
- $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR_TMP)/vmlinux-$(2).uImage \
+ echo -n '' > $(KDIR_TMP)/empty.bin
+ $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp \
+ -f $(KDIR_TMP)/vmlinux-$(2).uImage -F $(KDIR_TMP)/empty.bin \
-x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
-$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) \
-i $(KDIR)/image.tmp \
-o $(call sysupname,$(1),$(2))
+ $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR_TMP)/vmlinux-$(2).uImage \
+ -x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
-$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) -g \
-i $(KDIR)/image.tmp \
-o $(call factoryname,$(1),$(2))