summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2016-01-01 22:02:47 +0000
committerImre Kaloz <kaloz@openwrt.org>2016-01-01 22:02:47 +0000
commitcae1c44e4f2faab7174b7897b9078f2a2a3a5ac8 (patch)
tree8e66e447360f6cac21db8ad888384ec1794dee17
parent9242d27b4a91c2cf2e787d3a893de3a95890e717 (diff)
downloadmaster-31e0f0ae-cae1c44e4f2faab7174b7897b9078f2a2a3a5ac8.tar.gz
master-31e0f0ae-cae1c44e4f2faab7174b7897b9078f2a2a3a5ac8.tar.bz2
master-31e0f0ae-cae1c44e4f2faab7174b7897b9078f2a2a3a5ac8.zip
generic/4.4: update to 4.4-rc7
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 48059
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-4.4/010-net-remove-unnecessary-semicolon-in-netdev_alloc_pcp.patch24
-rw-r--r--target/linux/generic/patches-4.4/650-pppoe_header_pad.patch4
-rw-r--r--target/linux/generic/patches-4.4/700-swconfig.patch2
-rw-r--r--target/linux/generic/patches-4.4/901-debloat_sock_diag.patch2
-rw-r--r--target/linux/generic/patches-4.4/902-debloat_proc.patch2
6 files changed, 7 insertions, 31 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index b5b5fc48ce..97dc5921b7 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .23
LINUX_VERSION-4.1 = .13
LINUX_VERSION-4.3 =
-LINUX_VERSION-4.4 = -rc5
+LINUX_VERSION-4.4 = -rc7
LINUX_KERNEL_MD5SUM-3.18.23 = dc6d265ab38716be3676ac294b481ad8
LINUX_KERNEL_MD5SUM-4.1.13 = af9dd5d8f71185a64a8eccface15fc00
LINUX_KERNEL_MD5SUM-4.3 = 58b35794eee3b6d52ce7be39357801e7
-LINUX_KERNEL_MD5SUM-4.4-rc5 = 7516a83ce861c7b2324975c82c413157
+LINUX_KERNEL_MD5SUM-4.4-rc7 = 7f4b1d85736a180df73af45adde8937b
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/generic/patches-4.4/010-net-remove-unnecessary-semicolon-in-netdev_alloc_pcp.patch b/target/linux/generic/patches-4.4/010-net-remove-unnecessary-semicolon-in-netdev_alloc_pcp.patch
deleted file mode 100644
index b8b9a83022..0000000000
--- a/target/linux/generic/patches-4.4/010-net-remove-unnecessary-semicolon-in-netdev_alloc_pcp.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Felix Fietkau <nbd@openwrt.org>
-Date: Sat, 5 Dec 2015 13:53:36 +0100
-Subject: [PATCH] net: remove unnecessary semicolon in
- netdev_alloc_pcpu_stats()
-
-This semicolon causes a build error if the function call is wrapped in
-parentheses.
-
-Fixes: aabc92bbe3cf ("net: add __netdev_alloc_pcpu_stats() to indicate gfp flags")
-Reported-by: Imre Kaloz <kaloz@openwrt.org>
-Signed-off-by: Felix Fietkau <nbd@openwrt.org>
----
-
---- a/include/linux/netdevice.h
-+++ b/include/linux/netdevice.h
-@@ -2084,7 +2084,7 @@ struct pcpu_sw_netstats {
- })
-
- #define netdev_alloc_pcpu_stats(type) \
-- __netdev_alloc_pcpu_stats(type, GFP_KERNEL);
-+ __netdev_alloc_pcpu_stats(type, GFP_KERNEL)
-
- #include <linux/notifier.h>
-
diff --git a/target/linux/generic/patches-4.4/650-pppoe_header_pad.patch b/target/linux/generic/patches-4.4/650-pppoe_header_pad.patch
index 2804469952..adba206c08 100644
--- a/target/linux/generic/patches-4.4/650-pppoe_header_pad.patch
+++ b/target/linux/generic/patches-4.4/650-pppoe_header_pad.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/ppp/pppoe.c
+++ b/drivers/net/ppp/pppoe.c
-@@ -871,7 +871,7 @@ static int pppoe_sendmsg(struct socket *
+@@ -877,7 +877,7 @@ static int pppoe_sendmsg(struct socket *
goto end;
@@ -9,7 +9,7 @@
0, GFP_KERNEL);
if (!skb) {
error = -ENOMEM;
-@@ -879,7 +879,7 @@ static int pppoe_sendmsg(struct socket *
+@@ -885,7 +885,7 @@ static int pppoe_sendmsg(struct socket *
}
/* Reserve space for headers. */
diff --git a/target/linux/generic/patches-4.4/700-swconfig.patch b/target/linux/generic/patches-4.4/700-swconfig.patch
index 7f627418c5..122dd446c6 100644
--- a/target/linux/generic/patches-4.4/700-swconfig.patch
+++ b/target/linux/generic/patches-4.4/700-swconfig.patch
@@ -29,7 +29,7 @@
obj-$(CONFIG_DAVICOM_PHY) += davicom.o
--- a/include/uapi/linux/Kbuild
+++ b/include/uapi/linux/Kbuild
-@@ -387,6 +387,7 @@ header-y += stddef.h
+@@ -388,6 +388,7 @@ header-y += stddef.h
header-y += string.h
header-y += suspend_ioctls.h
header-y += swab.h
diff --git a/target/linux/generic/patches-4.4/901-debloat_sock_diag.patch b/target/linux/generic/patches-4.4/901-debloat_sock_diag.patch
index a33f33041a..b70f44efca 100644
--- a/target/linux/generic/patches-4.4/901-debloat_sock_diag.patch
+++ b/target/linux/generic/patches-4.4/901-debloat_sock_diag.patch
@@ -25,7 +25,7 @@
obj-$(CONFIG_PROC_FS) += net-procfs.o
--- a/net/core/sock.c
+++ b/net/core/sock.c
-@@ -1470,9 +1470,11 @@ void sk_destruct(struct sock *sk)
+@@ -1469,9 +1469,11 @@ void sk_destruct(struct sock *sk)
static void __sk_free(struct sock *sk)
{
diff --git a/target/linux/generic/patches-4.4/902-debloat_proc.patch b/target/linux/generic/patches-4.4/902-debloat_proc.patch
index 57ceeae82c..9f77858c55 100644
--- a/target/linux/generic/patches-4.4/902-debloat_proc.patch
+++ b/target/linux/generic/patches-4.4/902-debloat_proc.patch
@@ -173,7 +173,7 @@
goto err;
--- a/net/core/sock.c
+++ b/net/core/sock.c
-@@ -3036,6 +3036,8 @@ static __net_initdata struct pernet_oper
+@@ -3035,6 +3035,8 @@ static __net_initdata struct pernet_oper
static int __init proto_init(void)
{