summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-04-12 15:18:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-04-12 15:18:49 +0000
commitca240aa0df396f598ca70232a2df4cf6613a9499 (patch)
tree2df4fcb1f82bd9f85d7828e459c7e6a09b99f85a
parent4bd65101ad1662499a04a8cba9a6057a4e514a36 (diff)
downloadmaster-31e0f0ae-ca240aa0df396f598ca70232a2df4cf6613a9499.tar.gz
master-31e0f0ae-ca240aa0df396f598ca70232a2df4cf6613a9499.tar.bz2
master-31e0f0ae-ca240aa0df396f598ca70232a2df4cf6613a9499.zip
package ext4 (#4434)
SVN-Revision: 15218
-rw-r--r--package/kernel/modules/fs.mk22
-rw-r--r--target/linux/generic-2.6/config-2.6.281
2 files changed, 23 insertions, 0 deletions
diff --git a/package/kernel/modules/fs.mk b/package/kernel/modules/fs.mk
index 7f3ed0c941..bfdd45a009 100644
--- a/package/kernel/modules/fs.mk
+++ b/package/kernel/modules/fs.mk
@@ -113,6 +113,28 @@ endef
$(eval $(call KernelPackage,fs-ext3))
+define KernelPackage/fs-ext4
+ SUBMENU:=$(FS_MENU)
+ TITLE:=EXT4 filesystem support
+ KCONFIG:= \
+ CONFIG_EXT4DEV_COMPAT=y \
+ CONFIG_EXT4_FS_XATTR=y \
+ CONFIG_EXT4_FS_POSIX_ACL=y \
+ CONFIG_EXT4_FS_SECURITY=y \
+ CONFIG_EXT4_FS
+ DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
+ FILES:= \
+ $(LINUX_DIR)/fs/ext4/ext4.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,30,ext4)
+endef
+
+define KernelPackage/fs-ext4/description
+ Kernel module for EXT4 filesystem support
+endef
+
+$(eval $(call KernelPackage,fs-ext4))
+
+
define KernelPackage/fs-hfs
SUBMENU:=$(FS_MENU)
diff --git a/target/linux/generic-2.6/config-2.6.28 b/target/linux/generic-2.6/config-2.6.28
index 82fbb95070..5121fd1d66 100644
--- a/target/linux/generic-2.6/config-2.6.28
+++ b/target/linux/generic-2.6/config-2.6.28
@@ -789,6 +789,7 @@ CONFIG_ISDN_CAPI_MIDDLEWARE=y
# CONFIG_IXGB is not set
# CONFIG_JBD is not set
# CONFIG_JBD_DEBUG is not set
+# CONFIG_JBD2_DEBUG is not set
# CONFIG_JFFS2_CMODE_FAVOURLZO is not set
# CONFIG_JFFS2_CMODE_NONE is not set
CONFIG_JFFS2_CMODE_PRIORITY=y