summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-10-28 06:47:20 +0000
committerJohn Crispin <john@openwrt.org>2013-10-28 06:47:20 +0000
commitc81c814d6a823aa0859200208fb4478428faffe2 (patch)
tree357652f0c388a6cc4c8178c0f9e66ba92f8f253e
parentbe95e2415564e8f7cbd6e750dd86798a332e471e (diff)
downloadmaster-31e0f0ae-c81c814d6a823aa0859200208fb4478428faffe2.tar.gz
master-31e0f0ae-c81c814d6a823aa0859200208fb4478428faffe2.tar.bz2
master-31e0f0ae-c81c814d6a823aa0859200208fb4478428faffe2.zip
kernel: add packages for sdhci support
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38549
-rw-r--r--package/kernel/linux/modules/other.mk23
1 files changed, 22 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 453bedfc20..428bde6529 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -265,7 +265,6 @@ define KernelPackage/mmc
CONFIG_MMC_DEBUG=n \
CONFIG_MMC_UNSAFE_RESUME=n \
CONFIG_MMC_BLOCK_BOUNCE=y \
- CONFIG_MMC_SDHCI=n \
CONFIG_MMC_TIFM_SD=n \
CONFIG_MMC_WBSD=n \
CONFIG_SDIO_UART=n
@@ -282,6 +281,28 @@ endef
$(eval $(call KernelPackage,mmc))
+define KernelPackage/sdhci
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Secure Digital Host Controller Interface support
+ DEPENDS:=+kmod-mmc
+ KCONFIG:= \
+ CONFIG_MMC_SDHCI \
+ CONFIG_MMC_SDHCI_PLTFM \
+ CONFIG_MMC_SDHCI_PCI=n
+ FILES:= \
+ $(LINUX_DIR)/drivers/mmc/host/sdhci.ko \
+ $(LINUX_DIR)/drivers/mmc/host/sdhci-pltfm.ko
+
+ AUTOLOAD:=$(call AutoProbe,sdhci sdhci-pltfm,1)
+endef
+
+define KernelPackage/sdhci/description
+ Kernel support for SDHCI Hosts
+endef
+
+$(eval $(call KernelPackage,sdhci))
+
+
define KernelPackage/oprofile
SUBMENU:=$(OTHER_MENU)
TITLE:=OProfile profiling support