summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-04-16 12:01:09 +0000
committerJohn Crispin <john@openwrt.org>2014-04-16 12:01:09 +0000
commitc4aae8fbc5b4654e73c5c8a227abe4a06a24958c (patch)
treedd8ff3d99439dbfda0c7b6d3dc037b4336fd68b6
parentba62f78e2e53f14f5e6eb1f8f85096d65cdac66d (diff)
downloadmaster-31e0f0ae-c4aae8fbc5b4654e73c5c8a227abe4a06a24958c.tar.gz
master-31e0f0ae-c4aae8fbc5b4654e73c5c8a227abe4a06a24958c.tar.bz2
master-31e0f0ae-c4aae8fbc5b4654e73c5c8a227abe4a06a24958c.zip
lantiq: ARV7519RW22: several fixes
- Fix ethernet ports. - Clean DTS files. - WiFi is lantiq based (not supported yet), remove ath9k. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 40519
-rw-r--r--target/linux/lantiq/dts/ARV7519RW.dtsi134
-rw-r--r--target/linux/lantiq/dts/ARV7519RWV11.dts41
-rw-r--r--target/linux/lantiq/dts/ARV7519RWV12.dts41
-rw-r--r--target/linux/lantiq/xrx200/profiles/arv.mk10
4 files changed, 99 insertions, 127 deletions
diff --git a/target/linux/lantiq/dts/ARV7519RW.dtsi b/target/linux/lantiq/dts/ARV7519RW.dtsi
index 77904705f0..eff337e2a6 100644
--- a/target/linux/lantiq/dts/ARV7519RW.dtsi
+++ b/target/linux/lantiq/dts/ARV7519RW.dtsi
@@ -1,23 +1,54 @@
/include/ "vr9.dtsi"
/ {
-
model = "ARV7519 - Astoria Networks ARV7519RW22-A-LT";
-
+
chosen {
bootargs = "console=ttyLTQ0,115200 init=/etc/preinit";
};
-
+
memory@0 {
reg = <0x0 0x8000000>;
};
-
+
fpi@10000000 {
-
+ localbus@0 {
+ nor-boot@0 {
+ compatible = "lantiq,nor";
+ bank-width = <2>;
+ reg = <0 0x0 0x2000000>, <1 0x2000000 0x2000000>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "uboot";
+ reg = <0x0 0x60000>;
+ read-only;
+ };
+
+ partition@60000 {
+ label = "uboot_cfg";
+ reg = <0x60000 0x20000>;
+ read-only;
+ };
+
+ partition@80000 {
+ label = "firmware";
+ reg = <0x80000 0x1f00000>;
+ };
+
+ partition@1f80000 {
+ label = "boardconfig";
+ reg = <0x1f80000 0x80000>;
+ read-only;
+ };
+ };
+ };
+
gpio: pinmux@E100B10 {
pinctrl-names = "default";
pinctrl-0 = <&state_default>;
-
+
state_default: pinmux {
mdio {
lantiq,groups = "mdio";
@@ -63,20 +94,32 @@
reg = <0>;
mac-address = [ 00 11 22 33 44 55 ];
+ ethernet@1 {
+ compatible = "lantiq,xrx200-pdi-port";
+ reg = <4>;
+ phy-mode = "mii";
+ phy-handle = <&phy13>;
+ };
ethernet@2 {
compatible = "lantiq,xrx200-pdi-port";
+ reg = <5>;
+ phy-mode = "mii";
+ phy-handle = <&phy14>;
+ };
+ ethernet@3 {
+ compatible = "lantiq,xrx200-pdi-port";
reg = <2>;
- phy-mode = "gmii";
+ phy-mode = "mii";
phy-handle = <&phy11>;
};
- ethernet@3 {
+ ethernet@4 {
compatible = "lantiq,xrx200-pdi-port";
- reg = <4>;
- phy-mode = "gmii";
- phy-handle = <&phy13>;
+ reg = <3>;
+ phy-mode = "mii";
+ phy-handle = <&phy12>;
};
};
-
+
wan: interface@1 {
compatible = "lantiq,xrx200-pdi";
#address-cells = <1>;
@@ -84,7 +127,7 @@
reg = <1>;
mac-address = [ 00 11 22 33 44 56 ];
lantiq,wan;
- ethernet@4 {
+ ethernet@0 {
compatible = "lantiq,xrx200-pdi-port";
reg = <0>;
phy-mode = "rgmii";
@@ -102,11 +145,19 @@
};
phy11: ethernet-phy@11 {
reg = <0x11>;
- compatible = "lantiq,phy11g", "ethernet-phy-ieee802.3-c22";
+ compatible = "lantiq,phy22f", "ethernet-phy-ieee802.3-c22";
+ };
+ phy12: ethernet-phy@12 {
+ reg = <0x12>;
+ compatible = "lantiq,phy22f", "ethernet-phy-ieee802.3-c22";
};
phy13: ethernet-phy@13 {
reg = <0x13>;
- compatible = "lantiq,phy11g", "ethernet-phy-ieee802.3-c22";
+ compatible = "lantiq,phy22f", "ethernet-phy-ieee802.3-c22";
+ };
+ phy14: ethernet-phy@14 {
+ reg = <0x14>;
+ compatible = "lantiq,phy22f", "ethernet-phy-ieee802.3-c22";
};
};
};
@@ -116,7 +167,7 @@
gpios = <&gpio 32 0>;
lantiq,portmask = <0x3>;
};
-
+
pcie@d900000 {
status = "disabled";
compatible = "lantiq,pcie-xway";
@@ -133,54 +184,55 @@
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <100>;
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 20 1>;
+ linux,code = <0x211>;
+ };
reset {
label = "reset";
gpios = <&gpio 22 1>;
linux,code = <0x198>;
};
-
rfkill {
label = "rfkill";
gpios = <&gpio 45 1>;
linux,code = <0xf7>;
};
- wps {
- gpios = <&gpio 20 1>;
- linux,code = <0x211>;
- };
};
gpio-leds {
compatible = "gpio-leds";
- lan{ /* green */
+ lan_green {
label = "lan";
- gpios = <&gpio 02 1>;
+ gpios = <&gpio 2 1>;
};
- voice { /* green */
- label = "voice";
- gpios = <&gpio 29 1>;
- };
- message1 { /* red */
- label = "message1";
+ message_red {
+ label = "message_red";
gpios = <&gpio 10 1>;
};
- message2 { /* green */
- label = "message2";
- gpios = <&gpio 19 1>;
+ power_red {
+ label = "power";
+ gpios = <&gpio 14 1>;
+ default-state = "on";
};
- message3 { /* orange */
- label = "message3";
- gpios = <&gpio 28 1>;
- };
- alarm { /* blue */
+ alarm_blue {
label = "alarm";
gpios = <&gpio 15 1>;
};
- power { /* red */
- label = "power";
- gpios = <&gpio 14 1>;
- default-state = "on";
+ message_orange {
+ label = "message_orange";
+ gpios = <&gpio 19 1>;
+ };
+ message_green {
+ label = "message_green";
+ gpios = <&gpio 28 1>;
+ };
+ voice_green {
+ label = "voice";
+ gpios = <&gpio 29 1>;
};
};
};
diff --git a/target/linux/lantiq/dts/ARV7519RWV11.dts b/target/linux/lantiq/dts/ARV7519RWV11.dts
index c77ffb416d..7dadf144f9 100644
--- a/target/linux/lantiq/dts/ARV7519RWV11.dts
+++ b/target/linux/lantiq/dts/ARV7519RWV11.dts
@@ -1,50 +1,11 @@
/dts-v1/;
-
/include/ "ARV7519RW.dtsi"
/ {
- fpi@10000000 {
- localbus@0 {
- nor-boot@0 {
- compatible = "lantiq,nor";
- bank-width = <2>;
- reg = <0 0x0 0x2000000>, <1 0x2000000 0x2000000>;
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "uboot";
- reg = <0x000000000000 0x00060000>;
- read-only;
- };
-
- partition@60000 {
- label = "uboot_cfg";
- reg = <0x000000060000 0x00020000>;
- read-only;
- };
-
- partition@80000 {
- label = "firmware";
- reg = <0x000000080000 0x01f00000>;
- };
-
- partition@1f80000 {
- label = "boardconfig";
- reg = <0x000001f80000 0x00080000>;
- read-only;
-
- };
-
-
-
- };
- };
- };
gphy-xrx200 {
compatible = "lantiq,phy-xrx200";
- firmware = "lantiq/vr9_phy11g_a1x.bin"; /*VR9 1.1*/
+ firmware = "lantiq/vr9_phy22f_a1x.bin"; /*VR9 1.1*/
phys = [ 00 01 ];
};
};
diff --git a/target/linux/lantiq/dts/ARV7519RWV12.dts b/target/linux/lantiq/dts/ARV7519RWV12.dts
index 6f1bf51e1b..0dd7972d18 100644
--- a/target/linux/lantiq/dts/ARV7519RWV12.dts
+++ b/target/linux/lantiq/dts/ARV7519RWV12.dts
@@ -1,50 +1,11 @@
/dts-v1/;
-
/include/ "ARV7519RW.dtsi"
/ {
- fpi@10000000 {
- localbus@0 {
- nor-boot@0 {
- compatible = "lantiq,nor";
- bank-width = <2>;
- reg = <0 0x0 0x2000000>, <1 0x2000000 0x2000000>;
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "uboot";
- reg = <0x000000000000 0x00060000>;
- read-only;
- };
-
- partition@60000 {
- label = "uboot_cfg";
- reg = <0x000000060000 0x00020000>;
- read-only;
- };
-
- partition@80000 {
- label = "firmware";
- reg = <0x000000080000 0x01f00000>;
- };
-
- partition@1f80000 {
- label = "boardconfig";
- reg = <0x000001f80000 0x00080000>;
- read-only;
-
- };
-
-
-
- };
- };
- };
gphy-xrx200 {
compatible = "lantiq,phy-xrx200";
- firmware = "lantiq/vr9_phy11g_a2x.bin"; /*VR9 1.2*/
+ firmware = "lantiq/vr9_phy22f_a2x.bin"; /*VR9 1.2*/
phys = [ 00 01 ];
};
};
diff --git a/target/linux/lantiq/xrx200/profiles/arv.mk b/target/linux/lantiq/xrx200/profiles/arv.mk
index a32ec64ac0..776bf49a0a 100644
--- a/target/linux/lantiq/xrx200/profiles/arv.mk
+++ b/target/linux/lantiq/xrx200/profiles/arv.mk
@@ -37,9 +37,8 @@ endef
$(eval $(call Profile,VGV7519BRN))
define Profile/ARV7519RWV11
- NAME:=Livebox Astoria V1
- PACKAGES:=kmod-ath9k wpad-mini \
- kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ NAME:=Livebox Astoria ARV7519 v1.1
+ PACKAGES:=kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
ltq-vdsl-app ppp-mod-pppoa
@@ -48,9 +47,8 @@ endef
$(eval $(call Profile,ARV7519RWV11))
define Profile/ARV7519RWV12
- NAME:=Livebox Astoria V2
- PACKAGES:=kmod-ath9k wpad-mini \
- kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ NAME:=Livebox Astoria ARV7519 v1.2
+ PACKAGES:=kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
ltq-vdsl-app ppp-mod-pppoa