summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2007-10-24 21:08:54 +0000
committerTravis Kemen <thepeople@openwrt.org>2007-10-24 21:08:54 +0000
commitc4354c45897aa10459b150d28445a809dcff95f5 (patch)
tree5d86272c6c83bcd6a020b293d46fccd90f1337a5
parentd22f50a2526d6503a7f00c45e0679b77dd583c0e (diff)
downloadmaster-31e0f0ae-c4354c45897aa10459b150d28445a809dcff95f5.tar.gz
master-31e0f0ae-c4354c45897aa10459b150d28445a809dcff95f5.tar.bz2
master-31e0f0ae-c4354c45897aa10459b150d28445a809dcff95f5.zip
convert the rest of /etc/dnsmasq.conf to uci
SVN-Revision: 9440
-rw-r--r--package/dnsmasq/Makefile1
-rw-r--r--package/dnsmasq/files/dhcp.conf14
-rw-r--r--package/dnsmasq/files/dnsmasq.conf23
-rw-r--r--package/dnsmasq/files/dnsmasq.init14
4 files changed, 22 insertions, 30 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index cb723d528f..7dd55af8b8 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -46,7 +46,6 @@ define Package/dnsmasq/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
- $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
endef
diff --git a/package/dnsmasq/files/dhcp.conf b/package/dnsmasq/files/dhcp.conf
index fb55cf8b77..4904b02534 100644
--- a/package/dnsmasq/files/dhcp.conf
+++ b/package/dnsmasq/files/dhcp.conf
@@ -1,3 +1,17 @@
+config dnsmasq
+ option domainneeded 1
+ option boguspriv 1
+ option filterwin2k '0' #enable for dial on demand
+ option localise_queries 1
+ option local '/lan/'
+ option domain 'lan'
+ option expandhosts 1
+ option nonegcache 0
+ option authoritative 1
+ option readethers 1
+ option leasefile '/tmp/dhcp.leases'
+ option resolvfile '/tmp/resolv.conf.auto'
+
config dhcp
option interface lan
option start 100
diff --git a/package/dnsmasq/files/dnsmasq.conf b/package/dnsmasq/files/dnsmasq.conf
deleted file mode 100644
index c0a1958d71..0000000000
--- a/package/dnsmasq/files/dnsmasq.conf
+++ /dev/null
@@ -1,23 +0,0 @@
-# filter what we send upstream
-domain-needed
-bogus-priv
-# filterwin2k # enable for dial-on-demand
-localise-queries
-
-# allow /etc/hosts and dhcp lookups via *.lan
-local=/lan/
-domain=lan
-expand-hosts
-no-negcache
-resolv-file=/tmp/resolv.conf.auto
-
-dhcp-authoritative
-dhcp-leasefile=/tmp/dhcp.leases
-
-# use /etc/ethers for static hosts; same format as --dhcp-host
-# <hwaddr> <ipaddr>
-read-ethers
-
-# other useful options:
-# default route(s): dhcp-option=3,192.168.1.1,192.168.1.2
-# dns server(s): dhcp-option=6,192.168.1.1,192.168.1.2
diff --git a/package/dnsmasq/files/dnsmasq.init b/package/dnsmasq/files/dnsmasq.init
index ec595afce5..9797490c47 100644
--- a/package/dnsmasq/files/dnsmasq.init
+++ b/package/dnsmasq/files/dnsmasq.init
@@ -50,17 +50,19 @@ dnsmasq() {
append_bool "$cfg" localise_queries "-y"
append_bool "$cfg" readethers "-Z"
append_bool "$cfg" dbus "-l"
+ append_bool "$cfg" boguspriv "-b"
+ append_bool "$cfg" expandhosts "-E"
append_parm "$cfg" dnsforwardmax "-0"
append_parm "$cfg" port "-p"
append_parm "$cfg" ednspacket_max "-P"
append_parm "$cfg" dhcpleasemax "-X"
-
- config_get addnhosts "$cfg" addnhosts
- config_get interface "$cfg" interface
- config_get exceptinterface "$cfg" exceptinterface
- config_get queryport "$cfg" queryport
- config_get domain "$cfg" domain
+ append_parm "$cfg" "addnhosts" "-H"
+ append_parm "$cfg" "queryport" "-Q"
+ append_parm "$cfg" "domain" "-s"
+ append_parm "$cfg" "local" "-S"
+ append_parm "$cfg" "leasefile" "-l"
+ append_parm "$cfg" "resolvfile" "-r"
}
dhcp_subscrid_add() {