summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-09 03:37:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-09 03:37:31 +0000
commitc3a2acf7dbb47667c5f0cbabed9c451447337159 (patch)
tree7ccd9bbce1664a9c9728ae69ddb1203daa0a120b
parent8c97372e0dc7d496a9c0bae1ace912a4e7ec9540 (diff)
downloadmaster-31e0f0ae-c3a2acf7dbb47667c5f0cbabed9c451447337159.tar.gz
master-31e0f0ae-c3a2acf7dbb47667c5f0cbabed9c451447337159.tar.bz2
master-31e0f0ae-c3a2acf7dbb47667c5f0cbabed9c451447337159.zip
only run svn info if .svn exists
SVN-Revision: 9213
-rw-r--r--include/toplevel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index a9ca3a2806..3e39165349 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -16,7 +16,7 @@ include $(TOPDIR)/include/verbose.mk
ifneq ($(VERSION),)
OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
else
- REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+ REV:=$(if $(wildcard .svn/entries),$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' ))
ifneq ($(REV),)
OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
endif