summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2008-02-05 19:39:57 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2008-02-05 19:39:57 +0000
commitbfadfbe6a43895af80e3424df4c9b5c54fb851f7 (patch)
tree4b845bc06ba70ac1911576887b7e790a2f400fe6
parent752737ff5b40f598f34be6330009c3a0f8e91354 (diff)
downloadmaster-31e0f0ae-bfadfbe6a43895af80e3424df4c9b5c54fb851f7.tar.gz
master-31e0f0ae-bfadfbe6a43895af80e3424df4c9b5c54fb851f7.tar.bz2
master-31e0f0ae-bfadfbe6a43895af80e3424df4c9b5c54fb851f7.zip
Device Tree Compiler require more recent bison ...
SVN-Revision: 10398
-rw-r--r--tools/Makefile2
-rw-r--r--tools/bison/Makefile33
2 files changed, 34 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 022bbe1e9d..a73a79fcca 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -9,7 +9,7 @@
curdir:=tools
# subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) dtc
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison dtc
# builddir dependencies
$(curdir)/squashfs/compile := $(curdir)/lzma/install
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
new file mode 100644
index 0000000000..2b85612059
--- /dev/null
+++ b/tools/bison/Makefile
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bison
+PKG_VERSION:=2.3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/$(PKG_NAME)
+PKG_MD5SUM:=22327efdd5080e2b1acb6e560a04b43a
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+ $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+ $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))