summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-07 10:12:55 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-07 10:12:55 +0000
commitbe844a77830b89815227eec5eaf14d716fd81815 (patch)
treee2d9f30d0255af5857ec568a2229b7c60bbd4352
parent7178dc62a49aa0c89eb7b352736b3ba29a0024d8 (diff)
downloadmaster-31e0f0ae-be844a77830b89815227eec5eaf14d716fd81815.tar.gz
master-31e0f0ae-be844a77830b89815227eec5eaf14d716fd81815.tar.bz2
master-31e0f0ae-be844a77830b89815227eec5eaf14d716fd81815.zip
kmod-sound-i8x0 missing dependencies kmod-sound-i8x0 fails to include the ac97 modules and misspells the module name in AutoLoad.
SVN-Revision: 23283
-rw-r--r--package/kernel/modules/sound.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index 8c0ce65d51..7b647238db 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -102,8 +102,10 @@ endef
define KernelPackage/sound-i8x0
TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
KCONFIG:=CONFIG_SND_INTEL8X0
- FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.ko
- AUTOLOAD:=$(call AutoLoad,35,snd-i8x0)
+ FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.ko \
+ $(LINUX_DIR)/sound/ac97_bus.ko \
+ $(LINUX_DIR)/sound/pci/ac97/snd-ac97-codec.ko
+ AUTOLOAD:=$(call AutoLoad,35,ac97_bus snd-ac97-codec snd-intel8x0)
$(call AddDepends/sound)
endef