summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-08-21 11:29:04 +0000
committerJonas Gorski <jogo@openwrt.org>2014-08-21 11:29:04 +0000
commitbb6905bd23f945651ddbc0bd18d58dc163d37726 (patch)
tree45a237fedf74c793a7d6a4b9c9e837621004d11e
parent932305f854f2af68f7944d7cc80f27ffc2e1911b (diff)
downloadmaster-31e0f0ae-bb6905bd23f945651ddbc0bd18d58dc163d37726.tar.gz
master-31e0f0ae-bb6905bd23f945651ddbc0bd18d58dc163d37726.tar.bz2
master-31e0f0ae-bb6905bd23f945651ddbc0bd18d58dc163d37726.zip
dropbear: restore performance by disabling mips16
Disable MIPS16 to prevent it negatively affecting performance. Observed was a increase of connection delay from ~6 to ~11 seconds and a reduction of scp speed from 1.1MB/s to 710kB/s on brcm63xx. Fixes #15209. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 42250
-rw-r--r--package/network/services/dropbear/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index f793e9b8a7..d805f00cd3 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
PKG_VERSION:=2014.65
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
@@ -21,6 +21,7 @@ PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
PKG_CONFIG_DEPENDS:=CONFIG_DROPBEAR_ECC