summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-01-14 10:37:11 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-01-14 10:37:11 +0000
commitb99f5f9c4a706b9d991787599d1f1c422133f5dc (patch)
tree317e1c8d2d0034d35897bbcbb68e0272b1008d51
parent78ffb50c8ec3042ebf594ce66b3b348d1f6e791e (diff)
downloadmaster-31e0f0ae-b99f5f9c4a706b9d991787599d1f1c422133f5dc.tar.gz
master-31e0f0ae-b99f5f9c4a706b9d991787599d1f1c422133f5dc.tar.bz2
master-31e0f0ae-b99f5f9c4a706b9d991787599d1f1c422133f5dc.zip
ar71xx: build separate image for the WNDR3700 with NA region
SVN-Revision: 24982
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f1a9362184..9000063902 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -371,6 +371,10 @@ define Image/Build/WNDR3700
-B WNDR3700 -v OpenWrt.$(REVISION) \
-i $(call imgname,$(1),$(2))-sysupgrade.bin \
-o $(call imgname,$(1),$(2))-factory.img
+ $(STAGING_DIR_HOST)/bin/mkdniimg \
+ -B WNDR3700 -v OpenWrt.$(REVISION) -r "NA" \
+ -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+ -o $(call imgname,$(1),$(2))-factory-NA.img
endef
ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh