summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-03-07 12:59:19 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-03-07 12:59:19 +0000
commitb74308c4337b9309f2eb86ca54e6c10edebddc13 (patch)
treeb206df58e5ba505c00a6419d242b7c5d6402be83
parent9649777395e0c292fdf1e7b25d7615582d44cfa1 (diff)
downloadmaster-31e0f0ae-b74308c4337b9309f2eb86ca54e6c10edebddc13.tar.gz
master-31e0f0ae-b74308c4337b9309f2eb86ca54e6c10edebddc13.tar.bz2
master-31e0f0ae-b74308c4337b9309f2eb86ca54e6c10edebddc13.zip
only support EABI on ARM targets
SVN-Revision: 25928
-rw-r--r--include/kernel-defaults.mk2
-rw-r--r--package/apex/Makefile5
-rw-r--r--package/madwifi/Makefile12
-rw-r--r--rules.mk2
-rw-r--r--target/linux/at91/config-default1
-rw-r--r--target/linux/cns21xx/config-2.6.361
-rw-r--r--target/linux/cns21xx/config-2.6.371
-rw-r--r--target/linux/cns3xxx/config-default2
-rw-r--r--target/linux/ep93xx/config-2.6.302
-rw-r--r--target/linux/ep93xx/config-2.6.362
-rw-r--r--target/linux/ep93xx/config-2.6.372
-rw-r--r--target/linux/gemini/config-default1
-rw-r--r--target/linux/generic/config-2.6.302
-rw-r--r--target/linux/generic/config-2.6.312
-rw-r--r--target/linux/generic/config-2.6.322
-rw-r--r--target/linux/generic/config-2.6.342
-rw-r--r--target/linux/generic/config-2.6.352
-rw-r--r--target/linux/generic/config-2.6.362
-rw-r--r--target/linux/generic/config-2.6.372
-rw-r--r--target/linux/generic/config-2.6.382
-rw-r--r--target/linux/goldfish/config-2.6.302
-rw-r--r--target/linux/imx21/config-2.6.341
-rw-r--r--target/linux/iop32x/config-default1
-rw-r--r--target/linux/ixp4xx/config-2.6.321
-rw-r--r--target/linux/ixp4xx/config-2.6.371
-rw-r--r--target/linux/kirkwood/config-default1
-rw-r--r--target/linux/omap24xx/config-2.6.372
-rw-r--r--target/linux/omap24xx/config-2.6.382
-rw-r--r--target/linux/omap35xx/config-2.6.3222
-rw-r--r--target/linux/omap35xx/gumstix/config-2.6.342
-rw-r--r--target/linux/omap35xx/gumstix/config-2.6.362
-rw-r--r--target/linux/orion/config-default2
-rw-r--r--target/linux/pxa/config-default1
-rw-r--r--target/linux/realview/config-default2
-rw-r--r--target/linux/s3c24xx/openmoko-gta02/config-2.6.301
-rw-r--r--toolchain/Config.in15
-rw-r--r--toolchain/uClibc/Makefile2
37 files changed, 27 insertions, 82 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 082d79cd2b..9223e8413b 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -82,8 +82,6 @@ define Kernel/Configure/Default
echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
echo "# CONFIG_KALLSYMS_ALL is not set" >> $(LINUX_DIR)/.config.target
echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
- $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config.target
- $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config.target)
$(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config > $(LINUX_DIR)/.config.override
$(SCRIPT_DIR)/kconfig.pl 'm+' '+' $(LINUX_DIR)/.config.target /dev/null $(LINUX_DIR)/.config.override > $(LINUX_DIR)/.config
$(call Kernel/SetInitramfs)
diff --git a/package/apex/Makefile b/package/apex/Makefile
index 97ddee18d8..f17118e46c 100644
--- a/package/apex/Makefile
+++ b/package/apex/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -34,7 +34,6 @@ define build_apex
$(MAKE) -C $(PKG_BUILD_DIR) \
ARCH=arm \
$(1)_config
- $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(PKG_BUILD_DIR)/.config
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
KBUILD_HAVE_NLS=no \
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 5b0342a53b..6350a18052 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -74,25 +74,25 @@ ifeq ($(ARCH),i686)
HAL_TARGET:=i386-elf
endif
ifeq ($(BOARD),ixp4xx)
- HAL_TARGET:=xscale-be-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=xscale-be-elfgnueabi
endif
ifeq ($(BOARD),iop32x)
- HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=xscale-le-elfgnueabi
endif
ifeq ($(BOARD),kirkwood)
- HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=xscale-le-elfgnueabi
endif
ifeq ($(BOARD),orion)
- HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=xscale-le-elfgnueabi
endif
ifeq ($(BOARD),cns3xxx)
- HAL_TARGET:=arm11-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=arm11-le-elfgnueabi
endif
ifeq ($(ARCH),powerpc)
HAL_TARGET:=powerpc-be-elf
endif
ifeq ($(BOARD),gemini)
- HAL_TARGET:=armv4-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=armv4-le-elfgnueabi
endif
ifneq ($(CONFIG_TARGET_atheros),)
HAL_TARGET:=wisoc
diff --git a/rules.mk b/rules.mk
index efe7a6d65b..c2b0dcaff9 100644
--- a/rules.mk
+++ b/rules.mk
@@ -80,7 +80,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
LIBCV:=$(call qstrip,$(CONFIG_LIBC_VERSION))
REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-openwrt-linux$(if $(TARGET_SUFFIX),-$(TARGET_SUFFIX))
GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-openwrt-linux
- DIR_SUFFIX:=_$(LIBC)-$(LIBCV)$(if $(CONFIG_EABI_SUPPORT),_eabi)
+ DIR_SUFFIX:=_$(LIBC)-$(LIBCV)$(if $(CONFIG_arm),_eabi)
BUILD_DIR:=$(BUILD_DIR_BASE)/target-$(ARCH)$(ARCH_SUFFIX)$(DIR_SUFFIX)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))
STAGING_DIR:=$(TOPDIR)/staging_dir/target-$(ARCH)$(ARCH_SUFFIX)$(DIR_SUFFIX)
BUILD_DIR_TOOLCHAIN:=$(BUILD_DIR_BASE)/toolchain-$(ARCH)$(ARCH_SUFFIX)_gcc-$(GCCV)$(DIR_SUFFIX)
diff --git a/target/linux/at91/config-default b/target/linux/at91/config-default
index 51636b4500..c51a6ee54f 100644
--- a/target/linux/at91/config-default
+++ b/target/linux/at91/config-default
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_ARCH_AT572D940HF is not set
CONFIG_ARCH_AT91=y
diff --git a/target/linux/cns21xx/config-2.6.36 b/target/linux/cns21xx/config-2.6.36
index 118e1ec5a5..98f66abb66 100644
--- a/target/linux/cns21xx/config-2.6.36
+++ b/target/linux/cns21xx/config-2.6.36
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
CONFIG_ARCH_CNS21XX=y
CONFIG_ARCH_REQUIRE_GPIOLIB=y
diff --git a/target/linux/cns21xx/config-2.6.37 b/target/linux/cns21xx/config-2.6.37
index 6acc46d39e..ec42aa7eff 100644
--- a/target/linux/cns21xx/config-2.6.37
+++ b/target/linux/cns21xx/config-2.6.37
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
CONFIG_ARCH_CNS21XX=y
# CONFIG_ARCH_CNS3XXX is not set
diff --git a/target/linux/cns3xxx/config-default b/target/linux/cns3xxx/config-default
index 527a465102..b0a7d56abb 100644
--- a/target/linux/cns3xxx/config-default
+++ b/target/linux/cns3xxx/config-default
@@ -1,4 +1,3 @@
-CONFIG_AEABI=y
CONFIG_ALIGNMENT_TRAP=y
CONFIG_ARCH_CNS3XXX=y
CONFIG_ARCH_REQUIRE_GPIOLIB=y
@@ -138,7 +137,6 @@ CONFIG_MTD_M25P80=y
CONFIG_MTD_PHYSMAP=y
CONFIG_NLS=y
CONFIG_NR_CPUS=2
-CONFIG_OABI_COMPAT=y
CONFIG_OUTER_CACHE=y
CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_PAGE_OFFSET=0xC0000000
diff --git a/target/linux/ep93xx/config-2.6.30 b/target/linux/ep93xx/config-2.6.30
index 70e26e4f9c..28309626d1 100644
--- a/target/linux/ep93xx/config-2.6.30
+++ b/target/linux/ep93xx/config-2.6.30
@@ -1,4 +1,3 @@
-CONFIG_AEABI=y
CONFIG_ALIGNMENT_TRAP=y
CONFIG_ARCH_EP93XX=y
CONFIG_ARCH_HAS_HOLES_MEMORYMODEL=y
@@ -170,7 +169,6 @@ CONFIG_MTD_CFI_STAA=y
CONFIG_MTD_PHYSMAP=y
CONFIG_MTD_RAM=y
# CONFIG_NO_IOPORT is not set
-CONFIG_OABI_COMPAT=y
# CONFIG_OUTER_CACHE is not set
CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_PAGE_OFFSET=0xC0000000
diff --git a/target/linux/ep93xx/config-2.6.36 b/target/linux/ep93xx/config-2.6.36
index 48cdabdc08..6fb21942cd 100644
--- a/target/linux/ep93xx/config-2.6.36
+++ b/target/linux/ep93xx/config-2.6.36
@@ -1,4 +1,3 @@
-CONFIG_AEABI=y
CONFIG_ALIGNMENT_TRAP=y
CONFIG_ARCH_EP93XX=y
CONFIG_ARCH_HAS_HOLES_MEMORYMODEL=y
@@ -165,7 +164,6 @@ CONFIG_MTD_CFI_STAA=y
CONFIG_MTD_PHYSMAP=y
CONFIG_MTD_RAM=y
CONFIG_NEED_DMA_MAP_STATE=y
-CONFIG_OABI_COMPAT=y
CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_PAGE_OFFSET=0xC0000000
# CONFIG_PCI_SYSCALL is not set
diff --git a/target/linux/ep93xx/config-2.6.37 b/target/linux/ep93xx/config-2.6.37
index 48cdabdc08..6fb21942cd 100644
--- a/target/linux/ep93xx/config-2.6.37
+++ b/target/linux/ep93xx/config-2.6.37
@@ -1,4 +1,3 @@
-CONFIG_AEABI=y
CONFIG_ALIGNMENT_TRAP=y
CONFIG_ARCH_EP93XX=y
CONFIG_ARCH_HAS_HOLES_MEMORYMODEL=y
@@ -165,7 +164,6 @@ CONFIG_MTD_CFI_STAA=y
CONFIG_MTD_PHYSMAP=y
CONFIG_MTD_RAM=y
CONFIG_NEED_DMA_MAP_STATE=y
-CONFIG_OABI_COMPAT=y
CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_PAGE_OFFSET=0xC0000000
# CONFIG_PCI_SYSCALL is not set
diff --git a/target/linux/gemini/config-default b/target/linux/gemini/config-default
index 767cb9f2ff..57e4bb1ca2 100644
--- a/target/linux/gemini/config-default
+++ b/target/linux/gemini/config-default
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
CONFIG_ARCH_FLATMEM_HAS_HOLES=y
CONFIG_ARCH_GEMINI=y
diff --git a/target/linux/generic/config-2.6.30 b/target/linux/generic/config-2.6.30
index e041692a79..8d01b3228e 100644
--- a/target/linux/generic/config-2.6.30
+++ b/target/linux/generic/config-2.6.30
@@ -10,6 +10,7 @@
# CONFIG_ADFS_FS is not set
# CONFIG_ADM6996_PHY is not set
# CONFIG_ADM8211 is not set
+CONFIG_AEABI=y
# CONFIG_AFFS_FS is not set
# CONFIG_AFS_FS is not set
# CONFIG_AF_RXRPC is not set
@@ -1538,6 +1539,7 @@ CONFIG_NLS_DEFAULT="iso8859-1"
# CONFIG_NTFS_FS is not set
# CONFIG_NTFS_RW is not set
# CONFIG_NVRAM is not set
+# CONFIG_OABI_COMPAT is not set
# CONFIG_OCFS2_FS is not set
# CONFIG_OCF_BENCH is not set
# CONFIG_OCF_C7108 is not set
diff --git a/target/linux/generic/config-2.6.31 b/target/linux/generic/config-2.6.31
index 9436da6d5f..6757cf015c 100644
--- a/target/linux/generic/config-2.6.31
+++ b/target/linux/generic/config-2.6.31
@@ -11,6 +11,7 @@
# CONFIG_ADFS_FS is not set
# CONFIG_ADM6996_PHY is not set
# CONFIG_ADM8211 is not set
+CONFIG_AEABI=y
# CONFIG_AFFS_FS is not set
# CONFIG_AFS_FS is not set
# CONFIG_AF_RXRPC is not set
@@ -1536,6 +1537,7 @@ CONFIG_NLS_DEFAULT="iso8859-1"
# CONFIG_NTFS_FS is not set
# CONFIG_NTFS_RW is not set
# CONFIG_NVRAM is not set
+# CONFIG_OABI_COMPAT is not set
# CONFIG_OCFS2_FS is not set
# CONFIG_OCF_BENCH is not set
# CONFIG_OCF_C7108 is not set
diff --git a/target/linux/generic/config-2.6.32 b/target/linux/generic/config-2.6.32
index 95d4b13d3f..e5723b80af 100644
--- a/target/linux/generic/config-2.6.32
+++ b/target/linux/generic/config-2.6.32
@@ -11,6 +11,7 @@
# CONFIG_ADFS_FS is not set
# CONFIG_ADM6996_PHY is not set
# CONFIG_ADM8211 is not set
+CONFIG_AEABI=y
# CONFIG_AFFS_FS is not set
# CONFIG_AFS_FS is not set
# CONFIG_AF_RXRPC is not set
@@ -1619,6 +1620,7 @@ CONFIG_NLS_DEFAULT="iso8859-1"
# CONFIG_NTFS_FS is not set
# CONFIG_NTFS_RW is not set
# CONFIG_NVRAM is not set
+# CONFIG_OABI_COMPAT is not set
# CONFIG_OCFS2_FS is not set
# CONFIG_OCF_BENCH is not set
# CONFIG_OCF_C7108 is not set
diff --git a/target/linux/generic/config-2.6.34 b/target/linux/generic/config-2.6.34
index ab79c67dc9..b89a390f9f 100644
--- a/target/linux/generic/config-2.6.34
+++ b/target/linux/generic/config-2.6.34
@@ -13,6 +13,7 @@
# CONFIG_ADFS_FS is not set
# CONFIG_ADM6996_PHY is not set
# CONFIG_ADM8211 is not set
+CONFIG_AEABI=y
# CONFIG_AFFS_FS is not set
# CONFIG_AFS_FS is not set
# CONFIG_AF_RXRPC is not set
@@ -1702,6 +1703,7 @@ CONFIG_NLS_DEFAULT="iso8859-1"
# CONFIG_NTFS_FS is not set
# CONFIG_NTFS_RW is not set
# CONFIG_NVRAM is not set
+# CONFIG_OABI_COMPAT is not set
# CONFIG_OCFS2_FS is not set
# CONFIG_OCF_BENCH is not set
# CONFIG_OCF_C7108 is not set
diff --git a/target/linux/generic/config-2.6.35 b/target/linux/generic/config-2.6.35
index 5cee096621..7903c5f1d1 100644
--- a/target/linux/generic/config-2.6.35
+++ b/target/linux/generic/config-2.6.35
@@ -18,6 +18,7 @@
# CONFIG_ADIS16255 is not set
# CONFIG_ADM6996_PHY is not set
# CONFIG_ADM8211 is not set
+CONFIG_AEABI=y
# CONFIG_AFFS_FS is not set
# CONFIG_AFS_FS is not set
# CONFIG_AF_RXRPC is not set
@@ -1768,6 +1769,7 @@ CONFIG_NLS_DEFAULT="iso8859-1"
# CONFIG_NTFS_RW is not set
# CONFIG_NVRAM is not set
# CONFIG_N_GSM is not set
+# CONFIG_OABI_COMPAT is not set
# CONFIG_OCFS2_FS is not set
# CONFIG_OCF_BENCH is not set
# CONFIG_OCF_C7108 is not set
diff --git a/target/linux/generic/config-2.6.36 b/target/linux/generic/config-2.6.36
index 63255a9a8b..18acaf79a0 100644
--- a/target/linux/generic/config-2.6.36
+++ b/target/linux/generic/config-2.6.36
@@ -18,6 +18,7 @@ CONFIG_32BIT=y
# CONFIG_ADIS16255 is not set
# CONFIG_ADM6996_PHY is not set
# CONFIG_ADM8211 is not set
+CONFIG_AEABI=y
# CONFIG_AFFS_FS is not set
# CONFIG_AFS_FS is not set
# CONFIG_AF_RXRPC is not set
@@ -1655,6 +1656,7 @@ CONFIG_NLS_DEFAULT="iso8859-1"
# CONFIG_NXP_STB220 is not set
# CONFIG_NXP_STB225 is not set
# CONFIG_N_GSM is not set
+# CONFIG_OABI_COMPAT is not set
# CONFIG_OCFS2_FS is not set
# CONFIG_OCF_BENCH is not set
# CONFIG_OCF_C7108 is not set
diff --git a/target/linux/generic/config-2.6.37 b/target/linux/generic/config-2.6.37
index 2bf093f4b1..802b27a482 100644
--- a/target/linux/generic/config-2.6.37
+++ b/target/linux/generic/config-2.6.37
@@ -18,6 +18,7 @@ CONFIG_32BIT=y
# CONFIG_ADIS16255 is not set
# CONFIG_ADM6996_PHY is not set
# CONFIG_ADM8211 is not set
+CONFIG_AEABI=y
# CONFIG_AFFS_FS is not set
# CONFIG_AFS_FS is not set
# CONFIG_AF_RXRPC is not set
@@ -1692,6 +1693,7 @@ CONFIG_NLS_DEFAULT="iso8859-1"
# CONFIG_NXP_STB220 is not set
# CONFIG_NXP_STB225 is not set
# CONFIG_N_GSM is not set
+# CONFIG_OABI_COMPAT is not set
# CONFIG_OCFS2_FS is not set
# CONFIG_OCF_BENCH is not set
# CONFIG_OCF_C7108 is not set
diff --git a/target/linux/generic/config-2.6.38 b/target/linux/generic/config-2.6.38
index 2531b0a329..69066b81b3 100644
--- a/target/linux/generic/config-2.6.38
+++ b/target/linux/generic/config-2.6.38
@@ -18,6 +18,7 @@ CONFIG_32BIT=y
# CONFIG_ADIS16255 is not set
# CONFIG_ADM6996_PHY is not set
# CONFIG_ADM8211 is not set
+CONFIG_AEABI=y
# CONFIG_AFFS_FS is not set
# CONFIG_AFS_FS is not set
# CONFIG_AF_RXRPC is not set
@@ -1707,6 +1708,7 @@ CONFIG_NLS_DEFAULT="iso8859-1"
# CONFIG_NXP_STB220 is not set
# CONFIG_NXP_STB225 is not set
# CONFIG_N_GSM is not set
+# CONFIG_OABI_COMPAT is not set
# CONFIG_OCFS2_FS is not set
# CONFIG_OCF_BENCH is not set
# CONFIG_OCF_C7108 is not set
diff --git a/target/linux/goldfish/config-2.6.30 b/target/linux/goldfish/config-2.6.30
index abb11e4c68..3a4c34568a 100644
--- a/target/linux/goldfish/config-2.6.30
+++ b/target/linux/goldfish/config-2.6.30
@@ -1,4 +1,3 @@
-CONFIG_AEABI=y
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_APM_EMULATION is not set
CONFIG_ARCH_GOLDFISH=y
@@ -154,7 +153,6 @@ CONFIG_MTD_UBI=y
# CONFIG_NETDEV_1000 is not set
# CONFIG_NO_IOPORT is not set
# CONFIG_NO_USER_SPACE_SCREEN_ACCESS_CONTROL is not set
-# CONFIG_OABI_COMPAT is not set
# CONFIG_OUTER_CACHE is not set
CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_PAGE_OFFSET=0xC0000000
diff --git a/target/linux/imx21/config-2.6.34 b/target/linux/imx21/config-2.6.34
index b8fcf4b2d5..829c672d1e 100644
--- a/target/linux/imx21/config-2.6.34
+++ b/target/linux/imx21/config-2.6.34
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_ARCH_MX1 is not set
CONFIG_ARCH_MX2=y
diff --git a/target/linux/iop32x/config-default b/target/linux/iop32x/config-default
index 4e0681c140..70122bb6e0 100644
--- a/target/linux/iop32x/config-default
+++ b/target/linux/iop32x/config-default
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
CONFIG_ARCH_IOP32X=y
# CONFIG_ARCH_IQ31244 is not set
diff --git a/target/linux/ixp4xx/config-2.6.32 b/target/linux/ixp4xx/config-2.6.32
index 12f19ec31a..cb98ce339b 100644
--- a/target/linux/ixp4xx/config-2.6.32
+++ b/target/linux/ixp4xx/config-2.6.32
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_ARCH_ADI_COYOTE is not set
CONFIG_ARCH_IXCDP1100=y
diff --git a/target/linux/ixp4xx/config-2.6.37 b/target/linux/ixp4xx/config-2.6.37
index 0aa8158c6b..7bf63d52e9 100644
--- a/target/linux/ixp4xx/config-2.6.37
+++ b/target/linux/ixp4xx/config-2.6.37
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_ARCH_ADI_COYOTE is not set
CONFIG_ARCH_HAS_CPU_IDLE_WAIT=y
diff --git a/target/linux/kirkwood/config-default b/target/linux/kirkwood/config-default
index f4df95e509..77e646bd46 100644
--- a/target/linux/kirkwood/config-default
+++ b/target/linux/kirkwood/config-default
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
CONFIG_ARCH_KIRKWOOD=y
# CONFIG_ARCH_NUC93X is not set
diff --git a/target/linux/omap24xx/config-2.6.37 b/target/linux/omap24xx/config-2.6.37
index 8705722554..1ebc35de64 100644
--- a/target/linux/omap24xx/config-2.6.37
+++ b/target/linux/omap24xx/config-2.6.37
@@ -7,7 +7,6 @@
# CONFIG_ADIS16300 is not set
# CONFIG_ADIS16350 is not set
# CONFIG_ADIS16400 is not set
-CONFIG_AEABI=y
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_APM_EMULATION is not set
CONFIG_ARCH_HAS_CPUFREQ=y
@@ -409,7 +408,6 @@ CONFIG_NFS_V4_1=y
CONFIG_NLS=y
CONFIG_NOP_USB_XCEIV=m
CONFIG_NO_HZ=y
-# CONFIG_OABI_COMPAT is not set
# CONFIG_OMAP2_DSS is not set
CONFIG_OMAP_32K_TIMER=y
CONFIG_OMAP_32K_TIMER_HZ=128
diff --git a/target/linux/omap24xx/config-2.6.38 b/target/linux/omap24xx/config-2.6.38
index 8115f0c382..66cf181580 100644
--- a/target/linux/omap24xx/config-2.6.38
+++ b/target/linux/omap24xx/config-2.6.38
@@ -43,7 +43,6 @@ CONFIG_ADIS16204=m
# CONFIG_ADT7316 is not set
# CONFIG_ADT7410 is not set
# CONFIG_ADT75 is not set
-CONFIG_AEABI=y
CONFIG_ALIGNMENT_TRAP=y
CONFIG_APM_EMULATION=y
CONFIG_ARCH_HAS_CPUFREQ=y
@@ -454,7 +453,6 @@ CONFIG_NFS_V4_1=y
CONFIG_NLS=y
CONFIG_NOP_USB_XCEIV=m
CONFIG_NO_HZ=y
-# CONFIG_OABI_COMPAT is not set
# CONFIG_OMAP2_DSS is not set
CONFIG_OMAP_32K_TIMER=y
CONFIG_OMAP_32K_TIMER_HZ=128
diff --git a/target/linux/omap35xx/config-2.6.32 b/target/linux/omap35xx/config-2.6.32
index 9fd008b11e..83ac5afa4a 100644
--- a/target/linux/omap35xx/config-2.6.32
+++ b/target/linux/omap35xx/config-2.6.32
@@ -1,28 +1,7 @@
-
-#
-# AC97 GPIO expanders:
-# also be needed; see USB_STORAGE Help for more info
-# Android
-# At least one emulation must be selected
-# Audio decoders
-# Authenticated Encryption with Associated Data
-# Automatically generated make config: don't edit
-# Block modes
-# Boot options
-# Bus support
-# Caches
-# Camera Sensor Selection
-# CBUS support
-# CD-ROM/DVD Filesystems
-# CFG80211 needs to be enabled for MAC80211
-# Character devices
-# Ciphers
-# Compression
# CONFIG_AB3100_CORE is not set
# CONFIG_ACCESSIBILITY is not set
# CONFIG_ACORN_PARTITION is not set
# CONFIG_ADFS_FS is not set
-CONFIG_AEABI=y
# CONFIG_AFFS_FS is not set
# CONFIG_AF_RXRPC is not set
CONFIG_AIO=y
@@ -849,7 +828,6 @@ CONFIG_NLS=y
CONFIG_NO_HZ=y
# CONFIG_NOP_USB_XCEIV is not set
# CONFIG_NTFS_FS is not set
-# CONFIG_OABI_COMPAT is not set
# CONFIG_OCF_OCF is not set
# CONFIG_OCFS2_FS is not set
CONFIG_OMAP2_DSS_DEBUG_SUPPORT=y
diff --git a/target/linux/omap35xx/gumstix/config-2.6.34 b/target/linux/omap35xx/gumstix/config-2.6.34
index 8c9688793e..d20f13f50c 100644
--- a/target/linux/omap35xx/gumstix/config-2.6.34
+++ b/target/linux/omap35xx/gumstix/config-2.6.34
@@ -1,4 +1,3 @@
-CONFIG_AEABI=y
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_APM_EMULATION is not set
CONFIG_ARCH_HAS_CPUFREQ=y
@@ -287,7 +286,6 @@ CONFIG_NLS_CODEPAGE_437=y
CONFIG_NLS_ISO8859_1=y
CONFIG_NLS_UTF8=m
CONFIG_NO_HZ=y
-# CONFIG_OABI_COMPAT is not set
CONFIG_OMAP2_DSS=y
# CONFIG_OMAP2_DSS_COLLECT_IRQ_STATS is not set
CONFIG_OMAP2_DSS_DEBUG_SUPPORT=y
diff --git a/target/linux/omap35xx/gumstix/config-2.6.36 b/target/linux/omap35xx/gumstix/config-2.6.36
index 6bfd63803b..8a8ef1778a 100644
--- a/target/linux/omap35xx/gumstix/config-2.6.36
+++ b/target/linux/omap35xx/gumstix/config-2.6.36
@@ -1,4 +1,3 @@
-CONFIG_AEABI=y
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_APM_EMULATION is not set
CONFIG_ARCH_HAS_CPUFREQ=y
@@ -281,7 +280,6 @@ CONFIG_NLS_CODEPAGE_437=y
CONFIG_NLS_ISO8859_1=y
CONFIG_NLS_UTF8=m
CONFIG_NO_HZ=y
-# CONFIG_OABI_COMPAT is not set
CONFIG_OMAP2_DSS=y
# CONFIG_OMAP2_DSS_COLLECT_IRQ_STATS is not set
CONFIG_OMAP2_DSS_DEBUG_SUPPORT=y
diff --git a/target/linux/orion/config-default b/target/linux/orion/config-default
index 683d72b16e..c78a397abf 100644
--- a/target/linux/orion/config-default
+++ b/target/linux/orion/config-default
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_ARCH_DISCONTIGMEM_ENABLE is not set
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
@@ -179,7 +178,6 @@ CONFIG_NET_DSA=y
# CONFIG_NLS_ISO8859_1 is not set
# CONFIG_NLS_KOI8_R is not set
# CONFIG_NO_IOPORT is not set
-# CONFIG_OABI_COMPAT is not set
# CONFIG_ORION5X_WATCHDOG is not set
# CONFIG_OUTER_CACHE is not set
CONFIG_PAGEFLAGS_EXTENDED=y
diff --git a/target/linux/pxa/config-default b/target/linux/pxa/config-default
index 9b351346c7..31504dc099 100644
--- a/target/linux/pxa/config-default
+++ b/target/linux/pxa/config-default
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
CONFIG_APM_EMULATION=m
CONFIG_ARCH_GUMSTIX=y
diff --git a/target/linux/realview/config-default b/target/linux/realview/config-default
index 46abf4e237..3bc179c3fc 100644
--- a/target/linux/realview/config-default
+++ b/target/linux/realview/config-default
@@ -1,4 +1,3 @@
-CONFIG_AEABI=y
CONFIG_ALIGNMENT_TRAP=y
CONFIG_ARCH_HAS_BARRIERS=y
CONFIG_ARCH_REALVIEW=y
@@ -143,7 +142,6 @@ CONFIG_NEED_DMA_MAP_STATE=y
# CONFIG_NETDEV_1000 is not set
CONFIG_NLS=y
CONFIG_NR_CPUS=4
-CONFIG_OABI_COMPAT=y
CONFIG_OUTER_CACHE=y
CONFIG_OUTER_CACHE_SYNC=y
CONFIG_PAGE_OFFSET=0xC0000000
diff --git a/target/linux/s3c24xx/openmoko-gta02/config-2.6.30 b/target/linux/s3c24xx/openmoko-gta02/config-2.6.30
index 1be7f6dea4..6a4459dbe0 100644
--- a/target/linux/s3c24xx/openmoko-gta02/config-2.6.30
+++ b/target/linux/s3c24xx/openmoko-gta02/config-2.6.30
@@ -1,4 +1,3 @@
-# CONFIG_AEABI is not set
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_APM_EMULATION is not set
# CONFIG_AR6000_WLAN_DEBUG is not set
diff --git a/toolchain/Config.in b/toolchain/Config.in
index bc9e6df06d..61a54a3532 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -86,14 +86,6 @@ menuconfig TOOLCHAINOPTS
bool "Toolchain Options" if DEVEL
depends NEED_TOOLCHAIN
-config EABI_SUPPORT
- bool
- depends arm||armeb
- prompt "Enable EABI support" if TOOLCHAINOPTS
- default y
- help
- Enable ARM EABI support
-
menuconfig EXTRA_TARGET_ARCH
bool
prompt "Enable an extra toolchain target architecture" if TOOLCHAINOPTS
@@ -205,8 +197,5 @@ config LIBC_VERSION
config TARGET_SUFFIX
string
- default "gnueabi" if (USE_EGLIBC || USE_GLIBC) && EABI_SUPPORT
- default "gnu" if (USE_EGLIBC || USE_GLIBC) && !EABI_SUPPORT
- default "uclibcgnueabi" if USE_UCLIBC && EABI_SUPPORT
- default "uclibc" if USE_UCLIBC && !EABI_SUPPORT
-
+ default "gnueabi" if (USE_EGLIBC || USE_GLIBC)
+ default "uclibcgnueabi" if USE_UCLIBC
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 642f7fba4c..2d8e482977 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -74,8 +74,6 @@ define Host/Prepare
$(SED) 's,^KERNEL_HEADERS=.*,KERNEL_HEADERS=\"$(BUILD_DIR_TOOLCHAIN)/linux-dev/include\",g' \
-e 's,^.*UCLIBC_HAS_FPU.*,UCLIBC_HAS_FPU=$(if $(CONFIG_SOFT_FLOAT),n,y),g' \
-e 's,^.*UCLIBC_HAS_SOFT_FLOAT.*,UCLIBC_HAS_SOFT_FLOAT=$(if $(CONFIG_SOFT_FLOAT),y,n),g' \
- -e 's,^.*CONFIG_ARM_EABI.*,CONFIG_ARM_EABI=$(if $(CONFIG_EABI_SUPPORT),y,n),g' \
- -e 's,^.*CONFIG_ARM_OABI.*,CONFIG_ARM_OABI=$(if $(CONFIG_EABI_SUPPORT),n,y),g' \
-e 's,^.*UCLIBC_HAS_SHADOW.*,UCLIBC_HAS_SHADOW=$(if $(CONFIG_SHADOW_PASSWORDS),y,n),g' \
$(HOST_BUILD_DIR)/.config
$(MAKE) -C $(HOST_BUILD_DIR) oldconfig KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS"