summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-21 12:42:44 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-21 12:42:44 +0200
commitb570c0c88e8a020d9e21e556cf05cb3a702fff4d (patch)
treec27764f4fae1b93a26df866d7d87b034f21f28e5
parent72568ea3bd51a54a68669b4ecdba5879ad7be4cd (diff)
downloadmaster-31e0f0ae-b570c0c88e8a020d9e21e556cf05cb3a702fff4d.tar.gz
master-31e0f0ae-b570c0c88e8a020d9e21e556cf05cb3a702fff4d.tar.bz2
master-31e0f0ae-b570c0c88e8a020d9e21e556cf05cb3a702fff4d.zip
uhttpd: use configured distribution name for SSL certificate CN
Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--package/network/services/uhttpd/Makefile2
-rw-r--r--package/network/services/uhttpd/files/uhttpd.config2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index da5572b5fe..ab5ef64bb5 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -23,6 +23,7 @@ PKG_BUILD_DEPENDS = ustream-ssl
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
+include $(INCLUDE_DIR)/version.mk
define Package/uhttpd/default
SECTION:=net
@@ -124,6 +125,7 @@ define Package/uhttpd/install
$(INSTALL_BIN) ./files/uhttpd.init $(1)/etc/init.d/uhttpd
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) ./files/uhttpd.config $(1)/etc/config/uhttpd
+ $(VERSION_SED_SCRIPT) $(1)/etc/config/uhttpd
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/usr/sbin/uhttpd
endef
diff --git a/package/network/services/uhttpd/files/uhttpd.config b/package/network/services/uhttpd/files/uhttpd.config
index f8df4cdecb..db57095d12 100644
--- a/package/network/services/uhttpd/files/uhttpd.config
+++ b/package/network/services/uhttpd/files/uhttpd.config
@@ -119,4 +119,4 @@ config cert px5g
option location Unknown
# Common name
- option commonname Lede
+ option commonname '%D'