summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-03-17 21:41:07 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2016-03-17 21:41:07 +0000
commitb3aae4c6722b164477726b9120c919739d5c47c7 (patch)
tree1b664b1bc381b1ac160aa7cabb7a616686dc60a9
parent4d6c4994fc609ac40884631ced2d4e4127c8958e (diff)
downloadmaster-31e0f0ae-b3aae4c6722b164477726b9120c919739d5c47c7.tar.gz
master-31e0f0ae-b3aae4c6722b164477726b9120c919739d5c47c7.tar.bz2
master-31e0f0ae-b3aae4c6722b164477726b9120c919739d5c47c7.zip
kernel: update kernel 4.4 to version 4.4.6
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 49032
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm47xx/patches-4.4/901-Revert-bcma-switch-GPIO-portions-to-use-GPIOLIB_IRQC.patch4
-rw-r--r--target/linux/brcm63xx/patches-4.4/803-jffs2-work-around-unaligned-accesses-failing-on-bcm6.patch2
-rw-r--r--target/linux/cns3xxx/patches-4.4/032-pcie_no_of_domain_fix.patch14
-rw-r--r--target/linux/generic/patches-4.4/010-Kbuild-don-t-hardcode-path-to-awk-in-scripts-ld-vers.patch2
-rw-r--r--target/linux/generic/patches-4.4/103-MIPS-smp.c-Fix-uninitialised-temp_foreign_map.patch31
-rw-r--r--target/linux/generic/patches-4.4/111-jffs2-add-RENAME_EXCHANGE-support.patch2
-rw-r--r--target/linux/generic/patches-4.4/204-module_strip.patch4
-rw-r--r--target/linux/generic/patches-4.4/300-mips_expose_boot_raw.patch2
-rw-r--r--target/linux/generic/patches-4.4/304-mips_disable_fpu.patch2
-rw-r--r--target/linux/generic/patches-4.4/532-jffs2_eofdetect.patch2
11 files changed, 12 insertions, 57 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 5ee5462a65..6fcd81eaec 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .27
LINUX_VERSION-4.1 = .16
LINUX_VERSION-4.3 = .4
-LINUX_VERSION-4.4 = .4
+LINUX_VERSION-4.4 = .6
LINUX_KERNEL_MD5SUM-3.18.27 = 015a01bf84e7c6bc9952551b4da45044
LINUX_KERNEL_MD5SUM-4.1.16 = e4bf22fed49b476b47acffc00c03267a
LINUX_KERNEL_MD5SUM-4.3.4 = 5275d02132107c28b85f986bad576d91
-LINUX_KERNEL_MD5SUM-4.4.4 = 73d1835cfb6dd348d87c8c2413190c21
+LINUX_KERNEL_MD5SUM-4.4.6 = efc822dad2149e40cc908718a4fea1d3
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/brcm47xx/patches-4.4/901-Revert-bcma-switch-GPIO-portions-to-use-GPIOLIB_IRQC.patch b/target/linux/brcm47xx/patches-4.4/901-Revert-bcma-switch-GPIO-portions-to-use-GPIOLIB_IRQC.patch
index e686ba8528..eff8c8b811 100644
--- a/target/linux/brcm47xx/patches-4.4/901-Revert-bcma-switch-GPIO-portions-to-use-GPIOLIB_IRQC.patch
+++ b/target/linux/brcm47xx/patches-4.4/901-Revert-bcma-switch-GPIO-portions-to-use-GPIOLIB_IRQC.patch
@@ -20,7 +20,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
--- a/drivers/bcma/Kconfig
+++ b/drivers/bcma/Kconfig
-@@ -94,7 +94,7 @@ config BCMA_DRIVER_GMAC_CMN
+@@ -99,7 +99,7 @@ config BCMA_DRIVER_GMAC_CMN
config BCMA_DRIVER_GPIO
bool "BCMA GPIO driver"
depends on BCMA && GPIOLIB
@@ -223,7 +223,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
}
--- a/include/linux/bcma/bcma_driver_chipcommon.h
+++ b/include/linux/bcma/bcma_driver_chipcommon.h
-@@ -646,6 +646,7 @@ struct bcma_drv_cc {
+@@ -647,6 +647,7 @@ struct bcma_drv_cc {
spinlock_t gpio_lock;
#ifdef CONFIG_BCMA_DRIVER_GPIO
struct gpio_chip gpio;
diff --git a/target/linux/brcm63xx/patches-4.4/803-jffs2-work-around-unaligned-accesses-failing-on-bcm6.patch b/target/linux/brcm63xx/patches-4.4/803-jffs2-work-around-unaligned-accesses-failing-on-bcm6.patch
index 8b603e8b66..7a3c2f01c2 100644
--- a/target/linux/brcm63xx/patches-4.4/803-jffs2-work-around-unaligned-accesses-failing-on-bcm6.patch
+++ b/target/linux/brcm63xx/patches-4.4/803-jffs2-work-around-unaligned-accesses-failing-on-bcm6.patch
@@ -15,7 +15,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
--- a/fs/jffs2/nodelist.h
+++ b/fs/jffs2/nodelist.h
-@@ -255,7 +255,7 @@ struct jffs2_full_dirent
+@@ -259,7 +259,7 @@ struct jffs2_full_dirent
uint32_t ino; /* == zero for unlink */
unsigned int nhash;
unsigned char type;
diff --git a/target/linux/cns3xxx/patches-4.4/032-pcie_no_of_domain_fix.patch b/target/linux/cns3xxx/patches-4.4/032-pcie_no_of_domain_fix.patch
deleted file mode 100644
index 177afa1888..0000000000
--- a/target/linux/cns3xxx/patches-4.4/032-pcie_no_of_domain_fix.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/drivers/pci/pci.c
-+++ b/drivers/pci/pci.c
-@@ -4772,7 +4772,10 @@ int pci_get_new_domain_nr(void)
- void pci_bus_assign_domain_nr(struct pci_bus *bus, struct device *parent)
- {
- static int use_dt_domains = -1;
-- int domain = of_get_pci_domain_nr(parent->of_node);
-+ int domain = -1;
-+
-+ if (parent && parent->of_node)
-+ domain = of_get_pci_domain_nr(parent->of_node);
-
- /*
- * Check DT domain and use_dt_domains values.
diff --git a/target/linux/generic/patches-4.4/010-Kbuild-don-t-hardcode-path-to-awk-in-scripts-ld-vers.patch b/target/linux/generic/patches-4.4/010-Kbuild-don-t-hardcode-path-to-awk-in-scripts-ld-vers.patch
index 619a44b5ce..cb65ee360c 100644
--- a/target/linux/generic/patches-4.4/010-Kbuild-don-t-hardcode-path-to-awk-in-scripts-ld-vers.patch
+++ b/target/linux/generic/patches-4.4/010-Kbuild-don-t-hardcode-path-to-awk-in-scripts-ld-vers.patch
@@ -16,7 +16,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
# extract linker version number from stdin and turn into single number
+exec awk '
{
- gsub(".*)", "");
+ gsub(".*\\)", "");
split($1,a, ".");
print a[1]*10000000 + a[2]*100000 + a[3]*10000 + a[4]*100 + a[5];
exit
diff --git a/target/linux/generic/patches-4.4/103-MIPS-smp.c-Fix-uninitialised-temp_foreign_map.patch b/target/linux/generic/patches-4.4/103-MIPS-smp.c-Fix-uninitialised-temp_foreign_map.patch
deleted file mode 100644
index 6fe9d96ccc..0000000000
--- a/target/linux/generic/patches-4.4/103-MIPS-smp.c-Fix-uninitialised-temp_foreign_map.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From: James Hogan <james.hogan@imgtec.com>
-Date: Fri, 4 Mar 2016 10:10:51 +0000
-Subject: [PATCH] MIPS: smp.c: Fix uninitialised temp_foreign_map
-
-When calculate_cpu_foreign_map() recalculates the cpu_foreign_map
-cpumask it uses the local variable temp_foreign_map without initialising
-it to zero. Since the calculation only ever sets bits in this cpumask
-any existing bits at that memory location will remain set and find their
-way into cpu_foreign_map too. This could potentially lead to cache
-operations suboptimally doing smp calls to multiple VPEs in the same
-core, even though the VPEs share primary caches.
-
-Therefore initialise temp_foreign_map using cpumask_clear() before use.
-
-Fixes: cccf34e9411c ("MIPS: c-r4k: Fix cache flushing for MT cores")
-Signed-off-by: James Hogan <james.hogan@imgtec.com>
-Cc: Ralf Baechle <ralf@linux-mips.org>
-Cc: Paul Burton <paul.burton@imgtec.com>
-Cc: linux-mips@linux-mips.org
----
-
---- a/arch/mips/kernel/smp.c
-+++ b/arch/mips/kernel/smp.c
-@@ -121,6 +121,7 @@ static inline void calculate_cpu_foreign
- cpumask_t temp_foreign_map;
-
- /* Re-calculate the mask */
-+ cpumask_clear(&temp_foreign_map);
- for_each_online_cpu(i) {
- core_present = 0;
- for_each_cpu(k, &temp_foreign_map)
diff --git a/target/linux/generic/patches-4.4/111-jffs2-add-RENAME_EXCHANGE-support.patch b/target/linux/generic/patches-4.4/111-jffs2-add-RENAME_EXCHANGE-support.patch
index f9d5261cad..d718885654 100644
--- a/target/linux/generic/patches-4.4/111-jffs2-add-RENAME_EXCHANGE-support.patch
+++ b/target/linux/generic/patches-4.4/111-jffs2-add-RENAME_EXCHANGE-support.patch
@@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
else
/* Unlink the original */
ret = jffs2_do_unlink(c, JFFS2_INODE_INFO(old_dir_i),
-@@ -877,7 +883,7 @@ static int jffs2_rename (struct inode *o
+@@ -882,7 +888,7 @@ static int jffs2_rename (struct inode *o
return ret;
}
diff --git a/target/linux/generic/patches-4.4/204-module_strip.patch b/target/linux/generic/patches-4.4/204-module_strip.patch
index b2a3230dbe..225fc6927e 100644
--- a/target/linux/generic/patches-4.4/204-module_strip.patch
+++ b/target/linux/generic/patches-4.4/204-module_strip.patch
@@ -109,7 +109,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
config MODULES_TREE_LOOKUP
--- a/kernel/module.c
+++ b/kernel/module.c
-@@ -2840,6 +2840,7 @@ static struct module *setup_load_info(st
+@@ -2859,6 +2859,7 @@ static struct module *setup_load_info(st
static int check_modinfo(struct module *mod, struct load_info *info, int flags)
{
@@ -117,7 +117,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
const char *modmagic = get_modinfo(info, "vermagic");
int err;
-@@ -2865,6 +2866,7 @@ static int check_modinfo(struct module *
+@@ -2884,6 +2885,7 @@ static int check_modinfo(struct module *
pr_warn("%s: module is from the staging directory, the quality "
"is unknown, you have been warned.\n", mod->name);
}
diff --git a/target/linux/generic/patches-4.4/300-mips_expose_boot_raw.patch b/target/linux/generic/patches-4.4/300-mips_expose_boot_raw.patch
index e6a0c9ce0a..cd7d28a2c9 100644
--- a/target/linux/generic/patches-4.4/300-mips_expose_boot_raw.patch
+++ b/target/linux/generic/patches-4.4/300-mips_expose_boot_raw.patch
@@ -18,7 +18,7 @@ Acked-by: Rob Landley <rob@landley.net>
config CEVT_BCM1480
bool
-@@ -2809,6 +2806,18 @@ choice
+@@ -2810,6 +2807,18 @@ choice
bool "Bootloader kernel arguments if available"
endchoice
diff --git a/target/linux/generic/patches-4.4/304-mips_disable_fpu.patch b/target/linux/generic/patches-4.4/304-mips_disable_fpu.patch
index c8900c33e3..599e950ac8 100644
--- a/target/linux/generic/patches-4.4/304-mips_disable_fpu.patch
+++ b/target/linux/generic/patches-4.4/304-mips_disable_fpu.patch
@@ -26,7 +26,7 @@ v2: incorporated changes suggested by Jonas Gorski
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -2723,6 +2723,20 @@ config MIPS_O32_FP64_SUPPORT
+@@ -2724,6 +2724,20 @@ config MIPS_O32_FP64_SUPPORT
If unsure, say N.
diff --git a/target/linux/generic/patches-4.4/532-jffs2_eofdetect.patch b/target/linux/generic/patches-4.4/532-jffs2_eofdetect.patch
index 9cbe183138..8ce53d8bed 100644
--- a/target/linux/generic/patches-4.4/532-jffs2_eofdetect.patch
+++ b/target/linux/generic/patches-4.4/532-jffs2_eofdetect.patch
@@ -1,6 +1,6 @@
--- a/fs/jffs2/build.c
+++ b/fs/jffs2/build.c
-@@ -114,6 +114,16 @@ static int jffs2_build_filesystem(struct
+@@ -116,6 +116,16 @@ static int jffs2_build_filesystem(struct
dbg_fsbuild("scanned flash completely\n");
jffs2_dbg_dump_block_lists_nolock(c);