summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-30 20:28:57 +0000
committerJohn Crispin <john@openwrt.org>2015-05-30 20:28:57 +0000
commitb34988d5d0c6104eea40859224ecb84e9e8ab3ce (patch)
tree40ce4b510b99c60fb6a6f6091a85b8a9e9d2502c
parentbe16b184e287418456480eb3bb703dc6c7c47fd0 (diff)
downloadmaster-31e0f0ae-b34988d5d0c6104eea40859224ecb84e9e8ab3ce.tar.gz
master-31e0f0ae-b34988d5d0c6104eea40859224ecb84e9e8ab3ce.tar.bz2
master-31e0f0ae-b34988d5d0c6104eea40859224ecb84e9e8ab3ce.zip
lantiq: fix imagebuilder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45851
-rw-r--r--target/linux/lantiq/image/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 08d80ecb1d..e24e54a8ea 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -244,18 +244,23 @@ endif
endef
define Image/BuildKernelLoader/Template
- $(call PatchKernelLzma,$(1))
- $(call Image/BuildLoader/Template,$(1))
$(CP) $(KDIR)/loader-$(1).bin $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-loader
$(CP) $(KDIR)/vmlinux-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
- $(call PatchKernelLzma,$(1),-initramfs)
- $(call Image/BuildLoader/Template,$(1),-initramfs)
$(CP) $(KDIR)/loader-initramfs-$(1).bin $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-initramfs-loader
$(CP) $(KDIR)/vmlinux-initramfs-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-initramfs
endif
endef
+define Image/Prepare/Profile
+ $(call PatchKernelLzma,$(1))
+ $(call Image/BuildLoader/Template,$(1))
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call PatchKernelLzma,$(1),-initramfs)
+ $(call Image/BuildLoader/Template,$(1),-initramfs)
+endif
+endef
+
define Image/BuildKernelTPLink/Template
$(call PatchKernelLzma,$(1))
$(call TPLinkImageLzma,$(1),$(2))
@@ -433,6 +438,11 @@ Image/Build/Profile/VGV7519NOR=$(call Image/Build/$(1),$(1),VGV7519NOR)
Image/BuildKernel/Profile/VGV7519BRN=$(call Image/BuildKernel/Template,VGV7519BRN,$(1))
Image/Build/Profile/VGV7519BRN=$(call Image/Build/$(1),$(1),VGV7519BRN,5D00008000,0x12345678,$(1))
+define Image/Prepare
+ $(call Image/Prepare/Profile,VG3503J)
+ $(call Image/Prepare/Profile,VG3503J_V2)
+endef
+
endif