summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-20 21:09:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-20 21:09:04 +0000
commitb271605228a4a072159355d9e37ae724dd67356e (patch)
tree0d20adaacc080e0ec1d144bcbbe5e3e3f5d8df47
parentaf64ea8f8c6ac19a27d6ddb2b7508fe933696ae1 (diff)
downloadmaster-31e0f0ae-b271605228a4a072159355d9e37ae724dd67356e.tar.gz
master-31e0f0ae-b271605228a4a072159355d9e37ae724dd67356e.tar.bz2
master-31e0f0ae-b271605228a4a072159355d9e37ae724dd67356e.zip
add a menuconfig option for enabling KALLSYMS for the kernel
SVN-Revision: 14122
-rw-r--r--Config.in8
-rw-r--r--include/kernel-defaults.mk3
2 files changed, 11 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index a5b3364612..0f131f0623 100644
--- a/Config.in
+++ b/Config.in
@@ -117,6 +117,14 @@ config NO_STRIP
bool "Install unstripped binary on the target (useful for native compiling/debugging)"
default n
+comment "Kernel build options"
+
+config KERNEL_KALLSYMS
+ bool "Compile the kernel with symbol table information"
+ default n
+ help
+ This will give you more information in stack traces from kernel oopses
+
endmenu
menuconfig DEVEL
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 36f9174c91..4aa5c0ef18 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -86,6 +86,9 @@ define Kernel/Configure/2.6
endef
define Kernel/Configure/Default
$(LINUX_CONFCMD) > $(LINUX_DIR)/.config.target
+ echo "$(if $(CONFIG_KERNEL_KALLSYMS),CONFIG_KALLSYMS=y,# CONFIG_KALLSYMS is not set)" >> $(LINUX_DIR)/.config.target
+ echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
+ echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
$(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config > $(LINUX_DIR)/.config.override
$(SCRIPT_DIR)/kconfig.pl 'm+' $(LINUX_DIR)/.config.target $(LINUX_DIR)/.config.override > $(LINUX_DIR)/.config
$(call Kernel/SetInitramfs)