summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-24 13:53:31 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-24 13:53:31 +0000
commitb1b2b04639f1de1e2b8caa47d2d0d0f3869a7134 (patch)
treee056f52897b0661704602d81578e5d7da1e3140b
parent014b05878d64fb8408a4610fad07271be777f96c (diff)
downloadmaster-31e0f0ae-b1b2b04639f1de1e2b8caa47d2d0d0f3869a7134.tar.gz
master-31e0f0ae-b1b2b04639f1de1e2b8caa47d2d0d0f3869a7134.tar.bz2
master-31e0f0ae-b1b2b04639f1de1e2b8caa47d2d0d0f3869a7134.zip
package/kernel: move PCMCIA modules to their own file & submenu
SVN-Revision: 21136
-rw-r--r--package/kernel/modules/other.mk82
-rw-r--r--package/kernel/modules/pcmcia.mk90
-rw-r--r--target/linux/au1000/modules.mk2
-rw-r--r--target/linux/brcm63xx/modules.mk2
4 files changed, 92 insertions, 84 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index bc567fb65e..0b6d3fa1ea 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -101,88 +101,6 @@ endef
$(eval $(call KernelPackage,lp))
-define KernelPackage/pcmcia-core
- SUBMENU:=$(OTHER_MENU)
- TITLE:=PCMCIA/CardBus support
- DEPENDS:=@PCMCIA_SUPPORT
- KCONFIG:= \
- CONFIG_PCMCIA \
- CONFIG_CARDBUS \
- CONFIG_PCCARD \
- PCMCIA_DEBUG=n
-endef
-
-define KernelPackage/pcmcia-core/2.4
-# KCONFIG:= \
-# CONFIG_PCMCIA \
-# CONFIG_CARDBUS
- FILES:= \
- $(LINUX_DIR)/drivers/pcmcia/pcmcia_core.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/drivers/pcmcia/ds.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/drivers/pcmcia/yenta_socket.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,25,pcmcia_core ds yenta_socket)
-endef
-
-define KernelPackage/pcmcia-core/2.6
-# KCONFIG:= \
-# CONFIG_PCCARD \
-# CONFIG_PCMCIA \
-# PCMCIA_DEBUG=n
- FILES:= \
- $(LINUX_DIR)/drivers/pcmcia/pcmcia_core.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/drivers/pcmcia/pcmcia.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,25,pcmcia_core pcmcia)
-endef
-
-define KernelPackage/pcmcia-core/description
- Kernel support for PCMCIA/CardBus controllers
-endef
-
-$(eval $(call KernelPackage,pcmcia-core))
-
-
-define KernelPackage/pcmcia-yenta
- SUBMENU:=$(OTHER_MENU)
- TITLE:=yenta socket driver
- DEPENDS:=@LINUX_2_6 kmod-pcmcia-core
- KCONFIG:= \
- CONFIG_PCCARD_NONSTATIC \
- CONFIG_YENTA
- FILES:= \
- $(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/drivers/pcmcia/yenta_socket.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,41,rsrc_nonstatic yenta_socket)
-endef
-
-$(eval $(call KernelPackage,pcmcia-yenta))
-
-
-define KernelPackage/pcmcia-serial
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Serial devices support
- DEPENDS:=kmod-pcmcia-core
- KCONFIG:= \
- CONFIG_PCMCIA_SERIAL_CS \
- CONFIG_SERIAL_8250_CS
- AUTOLOAD:=$(call AutoLoad,45,serial_cs)
-endef
-
-define KernelPackage/pcmcia-serial/2.4
-# KCONFIG:=CONFIG_PCMCIA_SERIAL_CS
- FILES:=$(LINUX_DIR)/drivers/char/pcmcia/serial_cs.$(LINUX_KMOD_SUFFIX)
-endef
-
-define KernelPackage/pcmcia-serial/2.6
-# KCONFIG:=CONFIG_SERIAL_8250_CS
- FILES:=$(LINUX_DIR)/drivers/serial/serial_cs.$(LINUX_KMOD_SUFFIX)
-endef
-
-define KernelPackage/pcmcia-serial/description
- Kernel support for PCMCIA/CardBus serial devices
-endef
-
-$(eval $(call KernelPackage,pcmcia-serial))
-
define KernelPackage/ssb
SUBMENU:=$(OTHER_MENU)
TITLE:=Silicon Sonics Backplane glue code
diff --git a/package/kernel/modules/pcmcia.mk b/package/kernel/modules/pcmcia.mk
new file mode 100644
index 0000000000..5e5c765511
--- /dev/null
+++ b/package/kernel/modules/pcmcia.mk
@@ -0,0 +1,90 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+PCMCIA_MENU:=PCMCIA support
+
+define KernelPackage/pcmcia-core
+ SUBMENU:=$(PCMCIA_MENU)
+ TITLE:=PCMCIA/CardBus support
+ DEPENDS:=@PCMCIA_SUPPORT
+ KCONFIG:= \
+ CONFIG_PCMCIA \
+ CONFIG_CARDBUS \
+ CONFIG_PCCARD \
+ PCMCIA_DEBUG=n
+endef
+
+define KernelPackage/pcmcia-core/2.4
+# KCONFIG:= \
+# CONFIG_PCMCIA \
+# CONFIG_CARDBUS
+ FILES:= \
+ $(LINUX_DIR)/drivers/pcmcia/pcmcia_core.$(LINUX_KMOD_SUFFIX) \
+ $(LINUX_DIR)/drivers/pcmcia/ds.$(LINUX_KMOD_SUFFIX) \
+ $(LINUX_DIR)/drivers/pcmcia/yenta_socket.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,25,pcmcia_core ds yenta_socket)
+endef
+
+define KernelPackage/pcmcia-core/2.6
+# KCONFIG:= \
+# CONFIG_PCCARD \
+# CONFIG_PCMCIA \
+# PCMCIA_DEBUG=n
+ FILES:= \
+ $(LINUX_DIR)/drivers/pcmcia/pcmcia_core.$(LINUX_KMOD_SUFFIX) \
+ $(LINUX_DIR)/drivers/pcmcia/pcmcia.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,25,pcmcia_core pcmcia)
+endef
+
+define KernelPackage/pcmcia-core/description
+ Kernel support for PCMCIA/CardBus controllers
+endef
+
+$(eval $(call KernelPackage,pcmcia-core))
+
+
+define KernelPackage/pcmcia-yenta
+ SUBMENU:=$(PCMCIA_MENU)
+ TITLE:=yenta socket driver
+ DEPENDS:=@LINUX_2_6 kmod-pcmcia-core
+ KCONFIG:= \
+ CONFIG_PCCARD_NONSTATIC \
+ CONFIG_YENTA
+ FILES:= \
+ $(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.$(LINUX_KMOD_SUFFIX) \
+ $(LINUX_DIR)/drivers/pcmcia/yenta_socket.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,41,rsrc_nonstatic yenta_socket)
+endef
+
+$(eval $(call KernelPackage,pcmcia-yenta))
+
+
+define KernelPackage/pcmcia-serial
+ SUBMENU:=$(PCMCIA_MENU)
+ TITLE:=Serial devices support
+ DEPENDS:=kmod-pcmcia-core
+ KCONFIG:= \
+ CONFIG_PCMCIA_SERIAL_CS \
+ CONFIG_SERIAL_8250_CS
+ AUTOLOAD:=$(call AutoLoad,45,serial_cs)
+endef
+
+define KernelPackage/pcmcia-serial/2.4
+# KCONFIG:=CONFIG_PCMCIA_SERIAL_CS
+ FILES:=$(LINUX_DIR)/drivers/char/pcmcia/serial_cs.$(LINUX_KMOD_SUFFIX)
+endef
+
+define KernelPackage/pcmcia-serial/2.6
+# KCONFIG:=CONFIG_SERIAL_8250_CS
+ FILES:=$(LINUX_DIR)/drivers/serial/serial_cs.$(LINUX_KMOD_SUFFIX)
+endef
+
+define KernelPackage/pcmcia-serial/description
+ Kernel support for PCMCIA/CardBus serial devices
+endef
+
+$(eval $(call KernelPackage,pcmcia-serial))
diff --git a/target/linux/au1000/modules.mk b/target/linux/au1000/modules.mk
index cab44aa6cd..4c403f062a 100644
--- a/target/linux/au1000/modules.mk
+++ b/target/linux/au1000/modules.mk
@@ -6,7 +6,7 @@
#
define KernelPackage/pcmcia-au1000
- SUBMENU:=$(OTHER_MENU)
+ SUBMENU:=$(PCMCIA_MENU)
TITLE:=RMI/AMD Au1000 PCMCIA support
DEPENDS:=@TARGET_au1000 kmod-pcmcia-core
FILES:=$(LINUX_DIR)/drivers/pcmcia/au1x00_ss.$(LINUX_KMOD_SUFFIX)
diff --git a/target/linux/brcm63xx/modules.mk b/target/linux/brcm63xx/modules.mk
index e588fe9623..bfef919b17 100644
--- a/target/linux/brcm63xx/modules.mk
+++ b/target/linux/brcm63xx/modules.mk
@@ -22,7 +22,7 @@ $(eval $(call KernelPackage,bcm63xx-spi))
define KernelPackage/pcmcia-bcm63xx
- SUBMENU:=$(OTHER_MENU)
+ SUBMENU:=$(PCMCIA_MENU)
TITLE:=Broadcom BCM63xx PCMCIA support
DEPENDS:=@TARGET_brcm63xx kmod-pcmcia-core
KCONFIG:=CONFIG_PCMCIA_BCM63XX