summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-22 11:13:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-22 11:13:03 +0000
commitb15467640143248f44b53088585b2acbb1075fc2 (patch)
tree09e8c4f396146927df05e1ed9dc5977301959b79
parent9594ef907971134604b6d29a026944c95bc8f5ae (diff)
downloadmaster-31e0f0ae-b15467640143248f44b53088585b2acbb1075fc2.tar.gz
master-31e0f0ae-b15467640143248f44b53088585b2acbb1075fc2.tar.bz2
master-31e0f0ae-b15467640143248f44b53088585b2acbb1075fc2.zip
kernel/modules: package driver for the LM75 sensor
SVN-Revision: 16958
-rw-r--r--package/kernel/modules/hwmon.mk24
1 files changed, 20 insertions, 4 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index b09655a0a0..f259a7af93 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -26,6 +26,22 @@ endef
$(eval $(call KernelPackage,hwmon-core))
+define KernelPackage/hwmon-lm75
+ SUBMENU:=$(HWMON_MENU)
+ TITLE:=LM75 monitoring support
+ DEPENDS:=kmod-hwmon-core +kmod-i2c-core
+ KCONFIG:=CONFIG_SENSORS_LM75
+ FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,60,lm75)
+endef
+
+define KernelPackage/hwmon-lm75/description
+ Kernel module for lm75 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm75))
+
+
define KernelPackage/hwmon-lm77
SUBMENU:=$(HWMON_MENU)
TITLE:=LM77 monitoring support
@@ -34,9 +50,9 @@ define KernelPackage/hwmon-lm77
FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,60,lm77)
endef
-
+
define KernelPackage/hwmon-lm77/description
- Kernel module for LM77 thermal monitor chip
+ Kernel module for LM77 thermal monitor chip
endef
$(eval $(call KernelPackage,hwmon-lm77))
@@ -49,9 +65,9 @@ define KernelPackage/hwmon-lm90
FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,60,lm90)
endef
-
+
define KernelPackage/hwmon-lm90/description
- Kernel module for LM90 thermal monitor chip
+ Kernel module for LM90 thermal monitor chip
endef
$(eval $(call KernelPackage,hwmon-lm90))