summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-04 21:55:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-04 21:55:25 +0000
commitb0e669ee13e81300738f6fa799fad5eda4daaccd (patch)
tree7646a595483fb7a7fb788b30a7274a9c232bbd4c
parentb2a1f5e79bd22acba7d88089904cfa78adc5b46f (diff)
downloadmaster-31e0f0ae-b0e669ee13e81300738f6fa799fad5eda4daaccd.tar.gz
master-31e0f0ae-b0e669ee13e81300738f6fa799fad5eda4daaccd.tar.bz2
master-31e0f0ae-b0e669ee13e81300738f6fa799fad5eda4daaccd.zip
fix x86 image build order (fixes #3317)
SVN-Revision: 11359
-rw-r--r--target/linux/x86/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 7af434874e..6649670df6 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -96,9 +96,9 @@ define Image/BuildKernel
endef
define Image/Build
+ $(call Image/Build/$(1))
$(call Image/Build/grub,$(1))
$(call Image/Build/vdi,$(1))
- $(call Image/Build/$(1))
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).fs
$(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
endef