summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-08 08:01:39 +0000
committerJohn Crispin <john@openwrt.org>2014-10-08 08:01:39 +0000
commitb0a1c7dc0d825d5435111a8c005e1e8d5449ebee (patch)
tree6f92b9f3a78611ca9a6d2514967f328f071e8924
parent344a30452412d06c80de8515a72c828d678df33a (diff)
downloadmaster-31e0f0ae-b0a1c7dc0d825d5435111a8c005e1e8d5449ebee.tar.gz
master-31e0f0ae-b0a1c7dc0d825d5435111a8c005e1e8d5449ebee.tar.bz2
master-31e0f0ae-b0a1c7dc0d825d5435111a8c005e1e8d5449ebee.zip
include/download.mk: Add download mirrors for tools from GNU Savannah (bug #15184)
I defined a new download method @SAVANNAH in include/download.mk and scripts/download.pl, and converted quilt and qemu to use that method. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> SVN-Revision: 42840
-rw-r--r--include/download.mk2
-rwxr-xr-xscripts/download.pl5
-rw-r--r--tools/qemu/Makefile2
-rw-r--r--tools/quilt/Makefile2
4 files changed, 8 insertions, 3 deletions
diff --git a/include/download.mk b/include/download.mk
index cc4ffb0cfb..adaa2e6ac5 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -11,7 +11,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
define dl_method
$(strip \
$(if $(2),$(2), \
- $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% ftp://% http://% https://% file://%,$(1)),default, \
+ $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
$(if $(filter git://%,$(1)),git, \
$(if $(filter svn://%,$(1)),svn, \
$(if $(filter cvs://%,$(1)),cvs, \
diff --git a/scripts/download.pl b/scripts/download.pl
index d6a55b634c..9603e708d1 100755
--- a/scripts/download.pl
+++ b/scripts/download.pl
@@ -157,6 +157,11 @@ foreach my $mirror (@ARGV) {
push @mirrors, "ftp://ftp.belnet.be/mirror/ftp.gnu.org/gnu/$1";
push @mirrors, "ftp://ftp.mirror.nl/pub/mirror/gnu/$1";
push @mirrors, "http://mirror.switch.ch/ftp/mirror/gnu/$1";
+ } elsif ($mirror =~ /^\@SAVANNAH\/(.+)$/) {
+ push @mirrors, "http://download.savannah.gnu.org/releases/$1";
+ push @mirrors, "http://nongnu.uib.no/$1";
+ push @mirrors, "http://ftp.igh.cnrs.fr/pub/nongnu/$1";
+ push @mirrors, "http://download-mirror.savannah.gnu.org/releases/$1";
} elsif ($mirror =~ /^\@KERNEL\/(.+)$/) {
my @extra = ( $1 );
if ($filename =~ /linux-\d+\.\d+(?:\.\d+)?-rc/) {
diff --git a/tools/qemu/Makefile b/tools/qemu/Makefile
index 45d42d4883..34440ee853 100644
--- a/tools/qemu/Makefile
+++ b/tools/qemu/Makefile
@@ -10,7 +10,7 @@ PKG_NAME:=qemu
PKG_VERSION:=0.14.1
PKG_RELEASE:=1
-PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/qemu/
+PKG_SOURCE_URL:=@SAVANNAH/qemu
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_MD5SUM:=b6c713a8db638e173af53a62d5178640
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
index bda0b9764e..01b0bd298f 100644
--- a/tools/quilt/Makefile
+++ b/tools/quilt/Makefile
@@ -10,7 +10,7 @@ PKG_NAME:=quilt
PKG_VERSION:=0.63
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/$(PKG_NAME)
+PKG_SOURCE_URL:=@SAVANNAH/quilt
PKG_MD5SUM:=c0ef4beb58a6fa72563b955e70624b6e
include $(INCLUDE_DIR)/host-build.mk