summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-04-24 09:49:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-04-24 09:49:09 +0000
commitaf30e5e6bb5dcf1b615ea862fd8bb7b902c7a852 (patch)
treeeb504f20104d7c4a7d2df8f33e913bc23dfd5d5b
parent2cea3d3949996b0618a098cd5cd86e24d95f24ab (diff)
downloadmaster-31e0f0ae-af30e5e6bb5dcf1b615ea862fd8bb7b902c7a852.tar.gz
master-31e0f0ae-af30e5e6bb5dcf1b615ea862fd8bb7b902c7a852.tar.bz2
master-31e0f0ae-af30e5e6bb5dcf1b615ea862fd8bb7b902c7a852.zip
Enable hidraw support.
It's needed for dealing with certain UART-to-USB adapters built into e.g. weather stations, and increases the hid module package only slightly (e.g. on ar71xx: 35k -> 37k). Signed-off-by: Danny Baumann <dannybaumann@web.de> SVN-Revision: 36415
-rw-r--r--package/kernel/modules/input.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/modules/input.mk b/package/kernel/modules/input.mk
index 89575ae783..db31eb7f91 100644
--- a/package/kernel/modules/input.mk
+++ b/package/kernel/modules/input.mk
@@ -10,7 +10,7 @@ INPUT_MODULES_MENU:=Input modules
define KernelPackage/hid
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=HID Devices
- KCONFIG:=CONFIG_HID
+ KCONFIG:=CONFIG_HID CONFIG_HIDRAW=y
FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
AUTOLOAD:=$(call AutoLoad,61,hid)
$(call AddDepends/input,+kmod-input-evdev)