summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-10 08:56:43 +0000
committerJohn Crispin <john@openwrt.org>2014-10-10 08:56:43 +0000
commitaf1207b58c61eed1eaa86f5e670347b84fd75a09 (patch)
tree4cf021d68a852bae84996031b22b736c63e235b9
parent51a5ff094703c4db984284913d605e83e819d99c (diff)
downloadmaster-31e0f0ae-af1207b58c61eed1eaa86f5e670347b84fd75a09.tar.gz
master-31e0f0ae-af1207b58c61eed1eaa86f5e670347b84fd75a09.tar.bz2
master-31e0f0ae-af1207b58c61eed1eaa86f5e670347b84fd75a09.zip
ramips: add support for Nexx WT1520
Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net> SVN-Revision: 42867
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network3
-rwxr-xr-xtarget/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/WT1520.dts83
-rw-r--r--target/linux/ramips/image/Makefile8
-rw-r--r--target/linux/ramips/rt305x/profiles/nexx.mk17
8 files changed, 120 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index b07c96af31..26f384d318 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -210,6 +210,9 @@ case $board in
set_usb_led "wr8305rt:usb"
set_wifi_led "wr8305rt:wifi"
;;
+ wt1520)
+ set_wifi_led "rt2800pci-phy0::radio"
+ ;;
y1 |\
y1s)
ucidef_set_led_default "power" "power" "lenovo:blue:power" "1"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index c462fd8142..7ecec5fd27 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -110,7 +110,8 @@ ramips_setup_interfaces()
dir-615-h1 | \
hlk-rm04 | \
mzk-w300nh2 | \
- mzk-750dhp)
+ mzk-750dhp | \
+ wt1520)
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
ucidef_add_switch "switch0" "1" "1"
ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 6t"
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 9752eb22ec..aed7d6ab2e 100755
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -167,6 +167,9 @@ get_status_led() {
wnce2001)
status_led="netgear:green:power"
;;
+ nexx-wt1520)
+ status_led="nexx-wt1520:white:power"
+ ;;
mzk-w300nh2)
status_led="mzkw300nh2:green:power"
;;
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 68ff509a4e..08c5dff020 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -181,6 +181,9 @@ ramips_board_detect() {
*"NexAira BC2")
name="bc2"
;;
+ *"Nexx WT1520")
+ name="wt1520"
+ ;;
*"NW718")
name="nw718"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 4aec78099a..52f3f0a3ee 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -90,6 +90,7 @@ platform_check_image() {
wnce2001 | \
wli-tx4-ag300n | \
whr-g300n |\
+ wt1520 |\
ur-326n4g |\
ur-336un |\
wr512-3gn |\
diff --git a/target/linux/ramips/dts/WT1520.dts b/target/linux/ramips/dts/WT1520.dts
new file mode 100644
index 0000000000..dc0ad32f41
--- /dev/null
+++ b/target/linux/ramips/dts/WT1520.dts
@@ -0,0 +1,83 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+ compatible = "NEXXWT1520", "ralink,rt5350-soc";
+ model = "Nexx WT1520";
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x2000000>;
+ };
+
+ chosen {
+ bootargs = "console=ttyS1,57600";
+ };
+
+ palmbus@10000000 {
+ uart@500 {
+ status = "okay";
+ };
+
+ spi@b00 {
+ status = "okay";
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "w25q32";
+ reg = <0 0>;
+ linux,modalias = "m25p80", "s25fl064k";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x3b0000>;
+ };
+ };
+ };
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "jtag";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ ethernet@10100000 {
+ mtd-mac-address = <&factory 0x4>;
+ };
+
+ wmac@10180000 {
+ ralink,mtd-eeprom = <&factory 0>;
+ };
+
+ ehci@101c0000 {
+ status = "okay";
+ };
+
+ ohci@101c1000 {
+ status = "okay";
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index c365d9dbb5..93554489a6 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -550,6 +550,13 @@ Image/Build/Profile/WNCE2001=$(call BuildFirmware/WNCE2001/$(1),$(1),wnce2001,WN
Image/Build/Profile/WR512-3GN=$(call BuildFirmware/DefaultDualSize/$(1),$(1),wr512-3ng,WR512-3GN)
+define BuildFirmware/WT1520/initramfs
+ $(call BuildFirmware/OF/initramfs,$(1),$(2),$(3),$(4))
+endef
+BuildFirmware/WT1520/squashfs=$(call BuildFirmware/Default4M/squashfs,$(1),$(2),$(3),$(4))
+
+Image/Build/Profile/WT1520=$(call BuildFirmware/WT1520/$(1),$(1),wt1520,WT1520,WT1520)
+
Image/Build/Profile/UR-326N4G=$(call BuildFirmware/Default4M/$(1),$(1),ur-326n4g,UR-326N4G)
Image/Build/Profile/UR-336UN=$(call BuildFirmware/Default8M/$(1),$(1),ur-336un,UR-336UN)
@@ -638,6 +645,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/WNCE2001,$(1))
$(call Image/Build/Profile/WR512-3GN,$(1))
$(call Image/Build/Profile/WR6202,$(1))
+ $(call Image/Build/Profile/WT1520,$(1))
$(call Image/Build/Profile/X5,$(1))
$(call Image/Build/Profile/X8,$(1))
$(call Image/Build/Profile/XDXRN502J,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/nexx.mk b/target/linux/ramips/rt305x/profiles/nexx.mk
new file mode 100644
index 0000000000..eaef4c1abd
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/nexx.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WT1520
+ NAME:=Nexx WT1520
+ PACKAGES:=kmod-usb2
+endef
+
+define Profile/WT1520/Description
+ Package set for WT1520
+endef
+
+$(eval $(call Profile,WT1520))