summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-11-06 08:42:41 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-11-06 08:42:41 +0000
commitad2bd568f5b6476c1512b4419881d1260f5ad060 (patch)
treef86de8bd25b17b3e47c69fa4163b37526e8393a7
parent186b555e562e5b9bddf1169596c13e65c43fae75 (diff)
downloadmaster-31e0f0ae-ad2bd568f5b6476c1512b4419881d1260f5ad060.tar.gz
master-31e0f0ae-ad2bd568f5b6476c1512b4419881d1260f5ad060.tar.bz2
master-31e0f0ae-ad2bd568f5b6476c1512b4419881d1260f5ad060.zip
use host-side lzma decompression tool, lzma-4.32 from openwrt produces non-working bzImages, switch to 2.6.30, strip down kernel configuration
SVN-Revision: 18325
-rw-r--r--target/linux/rdc/Makefile2
-rw-r--r--target/linux/rdc/config-2.6.305
-rw-r--r--target/linux/rdc/patches-2.6.30/011-use_host_lzma.patch8
3 files changed, 11 insertions, 4 deletions
diff --git a/target/linux/rdc/Makefile b/target/linux/rdc/Makefile
index 185b67a214..9936b687c5 100644
--- a/target/linux/rdc/Makefile
+++ b/target/linux/rdc/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=RDC 321x
FEATURES:=squashfs jffs2 pci usb
CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
-LINUX_VERSION:=2.6.28.10
+LINUX_VERSION:=2.6.30.9
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/rdc/config-2.6.30 b/target/linux/rdc/config-2.6.30
index 5c2a715e04..c83aaa5aee 100644
--- a/target/linux/rdc/config-2.6.30
+++ b/target/linux/rdc/config-2.6.30
@@ -60,8 +60,7 @@ CONFIG_DEVPORT=y
# CONFIG_DMA_API_DEBUG is not set
# CONFIG_DMI is not set
CONFIG_DOUBLEFAULT=y
-CONFIG_EARLY_PRINTK=y
-# CONFIG_EARLY_PRINTK_DBGP is not set
+# CONFIG_EARLY_PRINTK is not set
# CONFIG_EDAC is not set
# CONFIG_EDD is not set
# CONFIG_EUROTECH_WDT is not set
@@ -302,7 +301,7 @@ CONFIG_X86_RDC321X=y
CONFIG_X86_REBOOTFIXUPS=y
# CONFIG_X86_RESERVE_LOW_64K is not set
# CONFIG_X86_UP_APIC is not set
-CONFIG_X86_VERBOSE_BOOTUP=y
+# CONFIG_X86_VERBOSE_BOOTUP is not set
CONFIG_X86_WP_WORKS_OK=y
CONFIG_X86_XADD=y
# CONFIG_ZONE_DMA32 is not set
diff --git a/target/linux/rdc/patches-2.6.30/011-use_host_lzma.patch b/target/linux/rdc/patches-2.6.30/011-use_host_lzma.patch
new file mode 100644
index 0000000000..5def7393fa
--- /dev/null
+++ b/target/linux/rdc/patches-2.6.30/011-use_host_lzma.patch
@@ -0,0 +1,8 @@
+--- a/scripts/Makefile.lib 2009-11-06 08:55:20.000000000 +0100
++++ b/scripts/Makefile.lib 2009-11-06 09:08:45.000000000 +0100
+@@ -204,4 +204,4 @@
+ # ---------------------------------------------------------------------------
+
+ quiet_cmd_lzma = LZMA $@
+-cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2 -eos
++cmd_lzma = (/usr/bin/lzma -9 -c $< ; $(size_append) $<) >$@ || (rm -f $@ ; false)