summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-06-15 22:11:50 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-06-15 22:11:50 +0000
commitaaf4aea141a6c0b33d6f4261e90151a51ef02a78 (patch)
tree23618078f2a992dcd4669332f8ddf67fad921a25
parent42dcce7e4ad4e00a73fada61ee6d724cad1b42cb (diff)
downloadmaster-31e0f0ae-aaf4aea141a6c0b33d6f4261e90151a51ef02a78.tar.gz
master-31e0f0ae-aaf4aea141a6c0b33d6f4261e90151a51ef02a78.tar.bz2
master-31e0f0ae-aaf4aea141a6c0b33d6f4261e90151a51ef02a78.zip
kernel: use bcma-hcd.ko on bcm53xx for ohci
On bcm53xx we still need usb-ohci to support USB 1.1 devices and it obviously needs bcma-hcd.ko that will init controller and register platform device. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 45994
-rw-r--r--package/kernel/linux/modules/usb.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 68f22cc05b..f27fcbd47f 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -300,6 +300,7 @@ $(eval $(call KernelPackage,usb-uhci,1))
define KernelPackage/usb-ohci
TITLE:=Support for OHCI controllers
DEPENDS:= \
+ +TARGET_bcm53xx:kmod-usb-bcma \
+TARGET_brcm47xx:kmod-usb-bcma \
+TARGET_brcm47xx:kmod-usb-ssb
KCONFIG:= \