summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-13 15:28:13 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-13 15:28:13 +0200
commitaad2b92603d5d317a4acac446ca2ed1e97ae7b02 (patch)
treee4fe0871d76ae899bd9b0852d5745cbc13f5ecb2
parentc47abdea2537894021c7c2c73ab6c1394a2d9d6a (diff)
downloadmaster-31e0f0ae-aad2b92603d5d317a4acac446ca2ed1e97ae7b02.tar.gz
master-31e0f0ae-aad2b92603d5d317a4acac446ca2ed1e97ae7b02.tar.bz2
master-31e0f0ae-aad2b92603d5d317a4acac446ca2ed1e97ae7b02.zip
include/package-dumpinfo.mk: introduce Repository values
Introduce a new dumpinfo field "Repository" which contains the name of the shared repository where the package will be hosted in. The name is chosen according to the following rules: - Name of the feed directory for any feed package, e.g. "Repository: luci" for "feeds/luci/applications/luci-app-firewall/Makefile" - The value "base" for any other, sharable package - Unset for any package flagged PKG_FLAGS:=nonshared Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--include/package-dumpinfo.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index 666e9635bb..04584d5b3a 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -41,7 +41,8 @@ $(if $(DEFAULT_VARIANT),Default-Variant: $(VARIANT)
)$(if $(BUILD_TYPES),Build-Types: $(BUILD_TYPES)
)Section: $(SECTION)
Category: $(CATEGORY)
-Title: $(TITLE)
+$(if $(filter nonshared,$(PKG_FLAGS)),,Repository: $(if $(FEED),$(FEED),base)
+)Title: $(TITLE)
Maintainer: $(MAINTAINER)
$(if $(USERID),Require-User: $(USERID)
)Source: $(PKG_SOURCE)