summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-09-04 13:34:18 +0200
committerFelix Fietkau <nbd@nbd.name>2016-09-04 13:35:11 +0200
commitaa53f78038d541052de8764323f6f26578327606 (patch)
tree6b727dbb60f75aee3db17e8e84777c143cba22d2
parenta810e7789ab52b65dca7c3dc74e0b96f44679950 (diff)
downloadmaster-31e0f0ae-aa53f78038d541052de8764323f6f26578327606.tar.gz
master-31e0f0ae-aa53f78038d541052de8764323f6f26578327606.tar.bz2
master-31e0f0ae-aa53f78038d541052de8764323f6f26578327606.zip
build: fix subtarget descriptions
Move Target/Description above the target.mk include Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--target/linux/adm8668/Makefile4
-rw-r--r--target/linux/apm821xx/Makefile8
-rw-r--r--target/linux/ar7/Makefile8
-rw-r--r--target/linux/arc770/Makefile4
-rw-r--r--target/linux/archs38/Makefile4
-rw-r--r--target/linux/arm64/Makefile4
-rw-r--r--target/linux/ath25/Makefile8
-rw-r--r--target/linux/au1000/Makefile6
-rw-r--r--target/linux/bcm53xx/Makefile4
-rw-r--r--target/linux/brcm2708/Makefile6
-rw-r--r--target/linux/brcm47xx/Makefile5
-rw-r--r--target/linux/brcm63xx/Makefile8
-rw-r--r--target/linux/cns3xxx/Makefile4
-rw-r--r--target/linux/mpc85xx/Makefile8
-rw-r--r--target/linux/octeon/Makefile5
-rw-r--r--target/linux/omap/Makefile8
-rw-r--r--target/linux/ppc40x/Makefile4
-rw-r--r--target/linux/ppc44x/Makefile4
-rw-r--r--target/linux/ramips/Makefile8
-rw-r--r--target/linux/realview/Makefile4
-rw-r--r--target/linux/xburst/Makefile4
21 files changed, 58 insertions, 60 deletions
diff --git a/target/linux/adm8668/Makefile b/target/linux/adm8668/Makefile
index 9695838999..ddca8d4a27 100644
--- a/target/linux/adm8668/Makefile
+++ b/target/linux/adm8668/Makefile
@@ -14,11 +14,11 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
KERNEL_PATCHVER:=3.18
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
Build firmware images for Infineon WildPass (ADM8668) based routers
(e.g. T-Mobile branded Linksys WRTU54G-TM)
endef
+include $(INCLUDE_DIR)/target.mk
+
$(eval $(call BuildTarget))
diff --git a/target/linux/apm821xx/Makefile b/target/linux/apm821xx/Makefile
index bd89c6b332..026466d86d 100644
--- a/target/linux/apm821xx/Makefile
+++ b/target/linux/apm821xx/Makefile
@@ -15,6 +15,10 @@ SUBTARGETS:=nand sata
KERNEL_PATCHVER:=4.4
+define Target/Description
+ Build images for AppliedMicro APM821xx based boards.
+endef
+
include $(INCLUDE_DIR)/target.mk
KERNELNAME:=uImage
@@ -22,8 +26,4 @@ KERNELNAME:=uImage
DEFAULT_PACKAGES += \
kmod-leds-gpio kmod-i2c-core kmod-gpio-button-hotplug
-define Target/Description
- Build images for AppliedMicro APM821xx based boards.
-endef
-
$(eval $(call BuildTarget))
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
index 1832e7b5e0..c5a6035b53 100644
--- a/target/linux/ar7/Makefile
+++ b/target/linux/ar7/Makefile
@@ -15,12 +15,12 @@ SUBTARGETS:=generic ac49x
KERNEL_PATCHVER:=3.18
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES+= swconfig
-
define Target/Description
Build firmware images for TI AR7 based routers.
endef
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= swconfig
+
$(eval $(call BuildTarget))
diff --git a/target/linux/arc770/Makefile b/target/linux/arc770/Makefile
index f917338aa4..6492529503 100644
--- a/target/linux/arc770/Makefile
+++ b/target/linux/arc770/Makefile
@@ -16,10 +16,10 @@ KERNEL_PATCHVER:=4.4
DEVICE_TYPE:=developerboard
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
Synopsys DesignWare boards
endef
+include $(INCLUDE_DIR)/target.mk
+
$(eval $(call BuildTarget))
diff --git a/target/linux/archs38/Makefile b/target/linux/archs38/Makefile
index 166d3d5540..be0d722893 100644
--- a/target/linux/archs38/Makefile
+++ b/target/linux/archs38/Makefile
@@ -17,10 +17,10 @@ KERNEL_PATCHVER:=4.4
DEVICE_TYPE:=developerboard
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
Synopsys DesignWare boards
endef
+include $(INCLUDE_DIR)/target.mk
+
$(eval $(call BuildTarget))
diff --git a/target/linux/arm64/Makefile b/target/linux/arm64/Makefile
index f0d23d0ebe..6bf89a7194 100644
--- a/target/linux/arm64/Makefile
+++ b/target/linux/arm64/Makefile
@@ -17,12 +17,12 @@ KERNEL_PATCHVER:=4.4
DEVICE_TYPE:=developerboard
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
Build multi-platform images for the ARMv8 instruction set architecture
endef
+include $(INCLUDE_DIR)/target.mk
+
KERNELNAME:=Image dtbs
$(eval $(call BuildTarget))
diff --git a/target/linux/ath25/Makefile b/target/linux/ath25/Makefile
index c09220db64..86db43fd66 100644
--- a/target/linux/ath25/Makefile
+++ b/target/linux/ath25/Makefile
@@ -14,12 +14,12 @@ MAINTAINER:=Sergey Ryazanov <ryazanov.s.a@gmail.com>
KERNEL_PATCHVER:=4.4
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
-
define Target/Description
Build firmware images for Atheros SoC boards
endef
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
+
$(eval $(call BuildTarget))
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index 7438e9b6df..0e019a9d67 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -15,14 +15,14 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
KERNEL_PATCHVER:=3.18
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-mini yamonenv
-
define Target/Description
Build firmware for RMI/AMD Alchemy 1500,1550 boards
(e.g. 4G-Systems Mesh/Access Cube, DBAu1550 ...)
endef
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += wpad-mini yamonenv
+
define Kernel/BuildImage
$(call Kernel/BuildImage/Default)
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
diff --git a/target/linux/bcm53xx/Makefile b/target/linux/bcm53xx/Makefile
index 717a44203a..917e55b5e3 100644
--- a/target/linux/bcm53xx/Makefile
+++ b/target/linux/bcm53xx/Makefile
@@ -15,12 +15,12 @@ CPU_TYPE:=cortex-a9
KERNEL_PATCHVER:=4.4
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
endef
+include $(INCLUDE_DIR)/target.mk
+
KERNELNAME:=zImage dtbs
DEFAULT_PACKAGES += swconfig wpad-mini nvram oseama otrx \
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index 9d0d921738..9240f66421 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -16,14 +16,14 @@ SUBTARGETS:=bcm2708 bcm2709 bcm2710
KERNEL_PATCHVER:=4.4
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
-
define Target/Description
Build firmware image for Broadcom BCM27xx SoC devices.
Currently produces SD Card image for Raspberry Pi.
endef
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+
KERNELNAME:=Image dtbs
$(eval $(call BuildTarget))
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index e0c44c8596..cb6d39fa22 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -15,13 +15,12 @@ MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
KERNEL_PATCHVER:=4.1
-include $(INCLUDE_DIR)/target.mk
-
-
define Target/Description
Build firmware images for Broadcom based BCM47xx/53xx routers with MIPS CPU, *not* ARM.
endef
+include $(INCLUDE_DIR)/target.mk
+
DEFAULT_PACKAGES += swconfig wpad-mini nvram otrx \
kmod-leds-gpio kmod-gpio-button-hotplug \
kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index 0dba065d0d..84e9a8d44e 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -15,14 +15,14 @@ FEATURES:=squashfs usb atm pci pcmcia usbgadget
KERNEL_PATCHVER:=4.4
MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
-
define Target/Description
Build firmware images for Broadcom based xDSL/routers
currently supports BCM6338, BCM6348 and BCM6358 based devices.
(e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
endef
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
+
$(eval $(call BuildTarget))
diff --git a/target/linux/cns3xxx/Makefile b/target/linux/cns3xxx/Makefile
index 52425821ec..c8d62519ce 100644
--- a/target/linux/cns3xxx/Makefile
+++ b/target/linux/cns3xxx/Makefile
@@ -16,13 +16,13 @@ MAINTAINER:=Felix Fietkau <nbd@nbd.name>
KERNEL_PATCHVER:=4.4
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
Build images for Cavium Networks Econa CNS3xxx based boards,
eg. the Gateworks Laguna family
endef
+include $(INCLUDE_DIR)/target.mk
+
KERNELNAME:=zImage
DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index efd48d7d41..7f986452c5 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -16,6 +16,10 @@ SUBTARGETS=generic p1020
KERNEL_PATCHVER:=4.4
+define Target/Description
+ Build images for the Freescale MPC85xx based boards.
+endef
+
include $(INCLUDE_DIR)/target.mk
KERNEL_IMAGES := zImage
@@ -27,8 +31,4 @@ DEFAULT_PACKAGES += \
kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
kmod-leds-gpio swconfig kmod-ath9k wpad-mini
-define Target/Description
- Build images for the Freescale MPC85xx based boards.
-endef
-
$(eval $(call BuildTarget))
diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
index 5cddd2de85..afef2ba67e 100644
--- a/target/linux/octeon/Makefile
+++ b/target/linux/octeon/Makefile
@@ -15,11 +15,10 @@ MAINTAINER:=John Crispin <john@phrozen.org>
KERNEL_PATCHVER:=4.4
-include $(INCLUDE_DIR)/target.mk
-
-
define Target/Description
Build firmware images for Cavium Networks Octeon-based boards.
endef
+include $(INCLUDE_DIR)/target.mk
+
$(eval $(call BuildTarget))
diff --git a/target/linux/omap/Makefile b/target/linux/omap/Makefile
index bc861f1117..91b9d9b20a 100644
--- a/target/linux/omap/Makefile
+++ b/target/linux/omap/Makefile
@@ -19,12 +19,12 @@ MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
KERNELNAME:=zImage dtbs
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
-
define Target/Description
TI OMAP boards
endef
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+
$(eval $(call BuildTarget))
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index fc85b03c29..3529bb3db5 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -15,12 +15,12 @@ MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
KERNEL_PATCHVER:=3.18
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
Build firmware images for AMCC/IBM PPC40x based boards.
endef
+include $(INCLUDE_DIR)/target.mk
+
KERNELNAME:=uImage cuImage.magicbox cuImage.openrb
$(eval $(call BuildTarget))
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index 17a3f5893a..5187cb3e23 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -15,12 +15,12 @@ MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
KERNEL_PATCHVER:=3.18
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
Build firmware images for AMCC/IBM PPC44x based boards.
endef
+include $(INCLUDE_DIR)/target.mk
+
KERNELNAME:=uImage cuImage.taishan
$(eval $(call BuildTarget))
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index b4ccaf64e1..51cd8f3e06 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -15,12 +15,12 @@ MAINTAINER:=John Crispin <john@phrozen.org>
KERNEL_PATCHVER:=4.4
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += \
- kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
-
define Target/Description
Build firmware images for Ralink RT288x/RT3xxx based boards.
endef
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+ kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+
$(eval $(call BuildTarget))
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
index c4f7a72e39..5bff0969d5 100644
--- a/target/linux/realview/Makefile
+++ b/target/linux/realview/Makefile
@@ -18,12 +18,12 @@ KERNEL_PATCHVER:=4.4
DEVICE_TYPE:=developerboard
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
Build images for ARM Ltd. Realview boards to be run with qemu
endef
+include $(INCLUDE_DIR)/target.mk
+
KERNELNAME:=zImage
$(eval $(call BuildTarget))
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index 258a743643..df499b6d53 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -16,10 +16,10 @@ KERNEL_PATCHVER:=3.18
DEVICE_TYPE=other
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
Build firmware images for XBurst JZ47x0 based boards.
endef
+include $(INCLUDE_DIR)/target.mk
+
$(eval $(call BuildTarget))