summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-06-01 14:37:11 +0000
committerNicolas Thill <nico@openwrt.org>2009-06-01 14:37:11 +0000
commita42072ddf48fbca02b16433c6cf6d841b432198a (patch)
tree3346ac1522dd65adda31a35d9309b3865d586602
parentca96019f8eba8c58773feac8b037c6f887a1977f (diff)
downloadmaster-31e0f0ae-a42072ddf48fbca02b16433c6cf6d841b432198a.tar.gz
master-31e0f0ae-a42072ddf48fbca02b16433c6cf6d841b432198a.tar.bz2
master-31e0f0ae-a42072ddf48fbca02b16433c6cf6d841b432198a.zip
broadcom-wl: fix broadcom (2.4) wireless sta (only) mode, adjust release number
This patch fixes an issue with the broadcom.sh configuration script when enabling sta mode. Currently sta mode works provided that you have an AP enabled as well but it doesn't work if you have a sta interface but not an AP. I found that merely reversing the order of the ap and apsta variables in the broadcom.sh script corrects this problem, and the attached patch does exactly that. Signed-off-by: Eric Bishop <ebishop@bu.edu> SVN-Revision: 16256
-rw-r--r--package/broadcom-wl/Makefile2
-rw-r--r--package/broadcom-wl/files/lib/wifi/broadcom.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/broadcom-wl/Makefile b/package/broadcom-wl/Makefile
index 3956092da6..ebc8287f44 100644
--- a/package/broadcom-wl/Makefile
+++ b/package/broadcom-wl/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=broadcom-wl
PKG_VERSION:=4.150.10.5.3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
WLC_VERSION:=0.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/broadcom-wl/files/lib/wifi/broadcom.sh b/package/broadcom-wl/files/lib/wifi/broadcom.sh
index 9ce49ab6fb..7d56c10e00 100644
--- a/package/broadcom-wl/files/lib/wifi/broadcom.sh
+++ b/package/broadcom-wl/files/lib/wifi/broadcom.sh
@@ -276,9 +276,9 @@ enable_broadcom() {
wlc stdin <<EOF
$ifdown
+apsta $apsta
ap $ap
${mssid:+mssid $mssid}
-apsta $apsta
infra $infra
${wet:+wet 1}
802.11d 0