summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-01-04 12:56:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-01-04 12:56:31 +0000
commita3ecf3d3dc8f077ae1d619dc907f0e699b1a55d2 (patch)
treeb311e613fac78af2fd086ee6bdf9a7c522a8d1e0
parent9bb47dc62d7c489f6bcc56a6629aa9eb5ded0764 (diff)
downloadmaster-31e0f0ae-a3ecf3d3dc8f077ae1d619dc907f0e699b1a55d2.tar.gz
master-31e0f0ae-a3ecf3d3dc8f077ae1d619dc907f0e699b1a55d2.tar.bz2
master-31e0f0ae-a3ecf3d3dc8f077ae1d619dc907f0e699b1a55d2.zip
Fix ssp enabling/disabling (#4388)
SVN-Revision: 13856
-rw-r--r--toolchain/gcc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index f11bd8c30b..9b3a34a0b5 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -52,9 +52,9 @@ SEP:=,
TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
ifeq ($(CONFIG_SSP_SUPPORT),y)
- SSP:=--enable-ssp
+ SSP:=--enable-libssp
else
- SSP:=--disable-ssp
+ SSP:=--disable-libssp
endif
EXTRA_TARGET=$(if $(CONFIG_EXTRA_TARGET_ARCH),--enable-biarch --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-uclibc)