summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-29 09:53:09 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-29 09:58:39 +0200
commit9eb155353a5f5137ec85a5b5b0287af63c544710 (patch)
treef85f053e7cec94091ac3e4ef5ceb8f2f5f90488a
parentd9a0a8c78f9ac42f7976aeb4152094213a4d8381 (diff)
downloadmaster-31e0f0ae-9eb155353a5f5137ec85a5b5b0287af63c544710.tar.gz
master-31e0f0ae-9eb155353a5f5137ec85a5b5b0287af63c544710.tar.bz2
master-31e0f0ae-9eb155353a5f5137ec85a5b5b0287af63c544710.zip
kernel: add a workaround to rebuild vdso.so.dbg after genvdso
Currently the build fails with 'arch/mips/vdso/vdso.so.dbg' already contains a '.MIPS.abiflags' section if the file already exists from a prior build. Add a makefile rule to force the rebuild of vdso.so.dbg if genvdso has has been changed to workaround the failure. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch b/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
new file mode 100644
index 0000000000..3d25e8062b
--- /dev/null
+++ b/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
@@ -0,0 +1,11 @@
+--- a/arch/mips/vdso/Makefile
++++ b/arch/mips/vdso/Makefile
+@@ -75,7 +75,7 @@ $(obj-vdso): KBUILD_AFLAGS := $(aflags-v
+
+ $(obj)/vdso.lds: KBUILD_CPPFLAGS := $(native-abi)
+
+-$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) FORCE
++$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) $(obj)/genvdso FORCE
+ $(call if_changed,vdsold)
+
+ $(obj)/vdso-image.c: $(obj)/vdso.so.dbg $(obj)/genvdso FORCE