summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-10 16:36:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-10 16:36:25 +0000
commit9e5df4a939a35377cfc8680bfed6b1c7aabe2dd0 (patch)
tree53c3626e953fc2f9a9dbaca31c191e2f4c49be64
parent6d0d89dc65d03f7a960a2cf0f774ab538723d212 (diff)
downloadmaster-31e0f0ae-9e5df4a939a35377cfc8680bfed6b1c7aabe2dd0.tar.gz
master-31e0f0ae-9e5df4a939a35377cfc8680bfed6b1c7aabe2dd0.tar.bz2
master-31e0f0ae-9e5df4a939a35377cfc8680bfed6b1c7aabe2dd0.zip
mac80211: move atheros/qca firmware to the linux-firmware package
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48179
-rw-r--r--package/firmware/linux-firmware/Makefile9
-rw-r--r--package/firmware/linux-firmware/qca.mk25
-rw-r--r--package/kernel/mac80211/Makefile17
3 files changed, 27 insertions, 24 deletions
diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
index 7dc2b78d38..2eaef05705 100644
--- a/package/firmware/linux-firmware/Makefile
+++ b/package/firmware/linux-firmware/Makefile
@@ -36,14 +36,5 @@ define Build/Compile
endef
-Package/ar3k-firmware = $(call Package/firmware-default,ath3k firmware)
-define Package/ar3k-firmware/install
- $(INSTALL_DIR) $(1)/lib/firmware/ar3k
- $(CP) \
- $(PKG_BUILD_DIR)/ar3k/*.dfu \
- $(1)/lib/firmware/ar3k
-endef
-$(eval $(call BuildPackage,ar3k-firmware))
-
include $(wildcard ./*.mk)
#$(eval $(call BuildPackage,linux-firmware))
diff --git a/package/firmware/linux-firmware/qca.mk b/package/firmware/linux-firmware/qca.mk
new file mode 100644
index 0000000000..7ad27ef388
--- /dev/null
+++ b/package/firmware/linux-firmware/qca.mk
@@ -0,0 +1,25 @@
+Package/ar3k-firmware = $(call Package/firmware-default,ath3k firmware)
+define Package/ar3k-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ar3k
+ $(CP) \
+ $(PKG_BUILD_DIR)/ar3k/*.dfu \
+ $(1)/lib/firmware/ar3k
+endef
+$(eval $(call BuildPackage,ar3k-firmware))
+
+Package/ath9k-htc-firmware = $(call Package/firmware-default,AR9271/AR7010 firmware)
+define Package/ath9k-htc-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ath9k_htc
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/ath9k_htc/htc_9271-1.4.0.fw \
+ $(PKG_BUILD_DIR)/ath9k_htc/htc_7010-1.4.0.fw \
+ $(1)/lib/firmware/ath9k_htc
+endef
+$(eval $(call BuildPackage,ath9k-htc-firmware))
+
+Package/carl9170-firmware = $(call Package/firmware-default,AR9170 firmware)
+define Package/carl9170-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/carl9170-1.fw $(1)/lib/firmware
+endef
+$(eval $(call BuildPackage,carl9170-firmware))
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index c626ef5608..998c3af570 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -252,7 +252,7 @@ define KernelPackage/ath9k-htc
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros 802.11n USB device support
URL:=https://wireless.wiki.kernel.org/en/users/drivers/ath9k
- DEPENDS+= @USB_SUPPORT +kmod-ath9k-common +kmod-usb-core
+ DEPENDS+= @USB_SUPPORT +kmod-ath9k-common +kmod-usb-core +ath9k-htc-firmware
FILES:= \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_htc.ko
AUTOLOAD:=$(call AutoProbe,ath9k_htc)
@@ -764,7 +764,7 @@ endef
define KernelPackage/carl9170
$(call KernelPackage/mac80211/Default)
TITLE:=Driver for Atheros AR9170 USB sticks
- DEPENDS:=@USB_SUPPORT +kmod-mac80211 +kmod-ath +kmod-usb-core +kmod-input-core +@DRIVER_11N_SUPPORT
+ DEPENDS:=@USB_SUPPORT +kmod-mac80211 +kmod-ath +kmod-usb-core +kmod-input-core +@DRIVER_11N_SUPPORT +carl9170-firmware
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/carl9170/carl9170.ko
AUTOLOAD:=$(call AutoProbe,carl9170)
endef
@@ -1742,14 +1742,6 @@ define Build/InstallDev
endef
-define KernelPackage/ath9k-htc/install
- $(INSTALL_DIR) $(1)/lib/firmware/ath9k_htc
- $(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/ath9k_htc/htc_9271-1.4.0.fw \
- $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/ath9k_htc/htc_7010-1.4.0.fw \
- $(1)/lib/firmware/ath9k_htc
-endef
-
define KernelPackage/b43/install
rm -rf $(1)/lib/firmware/
ifeq ($(CONFIG_B43_OPENFIRMWARE),y)
@@ -1818,11 +1810,6 @@ ifneq ($(CONFIG_BRCMFMAC_SDIO),)
endif
endef
-define KernelPackage/carl9170/install
- $(INSTALL_DIR) $(1)/lib/firmware
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/carl9170-1.fw $(1)/lib/firmware
-endef
-
define KernelPackage/cfg80211/install
$(INSTALL_DIR) $(1)/lib/wifi $(1)/lib/netifd/wireless
$(INSTALL_DATA) ./files/lib/wifi/mac80211.sh $(1)/lib/wifi